SOLVED: Script Editor Window Contents Missing

When I start up KM 9.2 on my Mac Pro (2019) running 11.4 or 11.5 I get an editor windows that shows the border, but no contents. I've tried uninstalling, deleting app + all files folders related in the Library subdirectories, then doing a clean re-install, but no luck. It absolutely was working previously, I unfortunately don't recall what version of the OS I was running at that time or what other variables might have changed. I try booting with no other services running and no change. I've double checked permissions...etc.

Definitely willing (want) to do the work to run through whatever triage steps people recommend in this case, just wondering if this has happened to anyone else and there is some known little wrinkle on my system to check for that might be the culprit. Nothing shows int he KM logs either other than startup and quitting/shutting down of the engine and/or editor. Thanks everyone.

First Things First ā€“ run the Interactive Help in the Keyboard Maestro Editor Help menu.

Then report back.


Iā€™d reach out directly to he support email

1 Like

Quitting the engine and then restarting through the Interactive Help system didn't help.
HOWEVER, 3rd time is the charm doing:

  1. Delete /Applications/Keyboard\
  2. Delete /Users/<your_username_here>/Library/Application\ Support/Keyboard\ Maestro

I still wish I knew what was causing the problems, because if it happened to me a couple times, it can happen to others and deleting and reinstalling the app and support files isn't ideal.

For what its worth, for support or other users curious, I've attached the log activity I captured while launching the app during the time it was misbehaving. After launching (while still capturing the logs) I quit the engine, start the engine, and seeing no change, quit the app. (21.0 KB)


@peternlewis ā€“ please note.

My guess would be that something in the system or security settings were screwed up relating to the application and reinstalling the Keyboard (which should never do anything) resolved the issue.

I've had a few cases recently where the system security permissions are screwed up, and deleting the Keyboard, and downloading a fresh copy, and then using the Finder to move that to the Applications folder cleared up the mess.

It could be things like Translocation (or some broken variant of that) or permissions in the app itself, that stopped the app being able to read its window structure files (xibs).