[SOLVED] Shortcut Not Working Anymore

Hello All,

For some time now one of my shortcuts has stopped working. The shortcut maps the system shortcut to hide Safari's sidebar to a custom shortcut.

I can't find any duplicate definitions and it worked before. The original shortcut in Safari works fine.

I prefer all my custom shortcuts to be defined centrally in KM - that's why I don't want to change them in the system shortcuts.

Any ideas what could be the problem?

Best regards

It could be for any number of reasons.
The Macro might be disabled.
The Group it is in might be disabled or not enabled for Safari.
Things might have changed in Safari since you made the Macro.

Try the below. It works for me to toggle showing or hiding the Sidebar with a single shortcut.

Show-Hide Safari Sidebar.kmmacros (2.7 KB)

Everything is enabled.

Thank you for your macro.

I have so far always defined the action as a shortcut and not the menu item itself.

However... it doesn't work, but I found the solution by playing around.

The macro group was defined to be available only in Safari. After I deleted and re-defined Safari there it worked.

It seems like the Safari definition may have been outdated (due to some updates)?!

Thanks for your suggestion


Yes, I like to re-define keys using menu items as that keeps the original default shortcut alongside my new one (or allows me to use the original shortcut to do something else using KM). Also, makes it easy to see at a glance what the Macro is actually doing.

Also, notice how the menu item is written as Show Sidebar|Hide Sidebar - this allows the the Macro to toggle the menu item depending on which menu item is showing at the time.

1 Like