Sorting, then Select all in Finder

I'm trying to perform actions on files inside a folder in the Finder.

The folder is open and frontmost when the action should start.

First, I want to sort by name. This part is working fine.

Next, I want to Select All files in that folder.

No files are selected when this runs.

I also tried this but I'm missing something; I can't figure out how to make it work even after reading the help article on it.

What am I doing wrong?

You aren't showing us the macro you're using so it's impossible to tell without guessing.

Here's a macro for you to try that works fine here:
Download Macro(s): Test Select All Finder.kmmacros (2.9 KB)


Keyboard Maestro Export

  • Macros are always disabled when imported into the Keyboard Maestro Editor.
    • The user must ensure the macro is enabled.
    • The user must also ensure the macro's parent macro-group is enabled.
System Information
  • macOS 13.6.1
  • Keyboard Maestro v11.0.2

Maybe you can learn what you're doing wrong from it :grinning:

I tried that macro prior to posting, but was not successful. I don't want to hold a key down, I just want everything in the folder to be selected so I can pass that to the next action.

Here is my entire macro, so far:

I'm aware that the action of attempting to Select All is in there twice, but neither one is working. If Command-a doesn't work, how do I use the Select Menu by Name function?

The resize part hasn't been built yet.

So what do you think your two simulate keystrokes do?

You're going to have to spell that out: what exactly did you do and what happened?

What are the Finders 'View Options'? Perhaps the Default setting is over-riding what you want to accomplish.

Unless I don't understand the macro, I'm expecting it to Select all items in the finder, or if that's not correct, hold down the a key for a bit and have all items selected.

Nothing is happening when I trigger the macro.

No 'tink' sound is played and nothing is highlighted in my window.

I imported the macro, assigned a keystroke, triggered the macro with the keystroke, and nothing happened.

I'm dumb here. I had assigned a keystroke in use by the system. Once I discovered that, it does let me select all.

Another question posted in another topic. Thanks for all your help.