Start Screen Saver Action (v9.0.6) fails to activate screen saver

I have a very simple action to start the screen saver. It had been working, but I have been noticing it now fails to start the screen saver on just one of my computers. It works fine on the other (where the macros are synced). I have tried right-clicking the Start Screen Saver action and executing Try Now. It just stares at me silently, with no screen saving goodness. I'm running Mojave 10.14.6. Any suggestions for what might be wrong?

Lock Screen.kmmacros (1.4 KB)

Curiously, I just had a problem with this the other day, with Keyboard Maestro and the Start Screen Saver action. It just would not work. I couldn't even get it to work by running AppleScript in Script Editor.

Then, a little while later, for no discernible reason, it worked again. I still don't know why. Just odd that we both had it within a few days of each other.

Thanks for the reply, @tjluoma. Unfortunately, I don't think timing is a factor. My problem has been going on for a while, I just haven't gotten around to bringing it up.

you can try to use shell script
open -a ScreenSaverEngine.app
or the appleScript
tell application "ScreenSaverEngine" to run