Still can't get KBM to work within Windows

Running KBM 10.2 (going to upgrade) on Sonoma 14.0 with Parallels 19.0.0 running Windows 11 Home (version 10.0.22000). I DID ensure "Send macOC System Shortcuts" is set to always, and read everything I could to see if others have this issue.

I have a number of text-substitution macros in KBM, and they work fine in the Mac environment. If I attempt to activate them in Windows (e.g. I type ##res to get résumé inserted in text), absolutely nothing happens. This has been going on for as long as I have been using KBM.

It's very likely my fault, but I cannot figure out how to resolve. Please help!

Have you ensured that your macros in question are in a macro group that is active when you’re in Parallels? I also use Parallels 19 and haven’t had any issues.

All my macro groups as set as Availabile in all applications, Available in all windows, Always activated, and Do not display in menu bar. Is there somewhere else I should be looking at that is Parallels-specific?

Then they should be working. Since you mention it’s been going on for awhile, I’m assuming that you have rebooted the computer at least once and that made no difference.

I wouldn’t know what the issue is to be honest because I’m pretty new to Parallels. But a quick search of the forum here shows that there are a number of Parallels-related topics, one of them might shed some more light on the issue until somebody more experienced chimes in.

Search results for 'parallels' - Keyboard Maestro Discourse

Thank you. It's a mystery to me. I'm sure it's a configuration setting in Parallels, MacOS, or Windows, but not an obvious one. Hopefully someone has an idea...

(Read all the "Parallels"-related entries, no joy.) Did the Interactive Help process and noted that the macro never fires when the initiating string is typed in Windows. Tells me that Windows is not passing the string on to the Mac where KM can see it and act on it. I looked through all the Parallels configuration menus to see if there was something obvious that might be blocking this communication, but nothing jumped out at me. Any ideas?

Do you run W11 in coherence mode? I’m not sure if that would make a difference but you might try triggering the macro while it’s in coherence mode (or vice versa).

1 Like

Great idea, but nfortunately it does not resolve the problem (but I learned what Coherence mode is!).

So, it's 2024 and I've had this problem since the Big Sur update, when life suddenly changed. Many KM, Parallels, and MacOS updates have happened since, and I seem to be the only one with the problem.

In a nutshell: When I type a macro within Windows, it does not reach KM (as revealed by the KM diagnostics). For some reason, the string isn't being passed along. I'm sure it's a setting issue in KM, Windows, Parallels, or MacOS, but nothing tried so far has worked.

To those using KM inside Parallels, did you do anything special to get it to function?

Works here too.

Screenshot 2024-03-10 at 08.54.11
Screenshot 2024-03-10 at 08.55.06

Screenshot 2024-03-10 at 08.55.41

It really seems like I am the only one experiencing this issue. What setting could be blocking Windows from transmitting the string out to KM?

Have you tried inserting the string by paste typing?

And I guess that you have the same settings here:

Alyb, that wouldn’t help because KB is never aware that I have asked it to do anything.


Brian, you can either send me relevant screenshots of your settings directly ( or post them here. I'll compare them with my own settings.