Stream Deck Does Not Launch Kmtrigger URL Anymore


after upgrading to KM 10, I noticed my Stream Deck won't launch kmtrigger URL schemes any longer. I'm not sure, though, if the culprit is KM, Stream Deck or even the newly updated MacOS Monterey.

Stream Deck triggers macros using the KM Plugin just fine with device key triggers.
Stream Deck uses standard and other custom URLs (x-bunch://, zoommtg://) also just fine.

The kmtrigger URLs work fine when using LaunchBar or Terminal.
They used to work in Stream Deck, too. I haven't used them in some time and hence do not know which update broke them.

I toggled the System & Privacy settings for both of them – that didn't do anything.

Any idea where to look would be appreciated.

If anyone else has this problem, I have two workarounds:

(1) Use the Open App action and specify as app "open -u kmtrigger://macro=…"

(2) Use the KM Link plugin by

I really would prefer using the standard URL scheme.
Thanks for any suggestion!


Hi There!

I am new here due the above topic. Does anyone know whether they might change this so it will work again?

Would be a lot of work for me to rearrange all of that.

If the URLs work fine from elsewhere, and just not from within Stream Deck, then that sounds like a Stream Deck issue, so perhaps you should ask them why they are not working.

Thank you, for your response, Peter. That was my guess, too. I wrote to the Stream Deck support but haven't heard back from them. It also hasn't been addressed in their latest update. It is curious, though, that the problem in Stream Deck is limited to kmtrigger-URLs while the others I use still work.

I'm seeing the same behavior, and also from a different (but similar) device: Loupedeck Live.

Strangely, all app-specific URLs for other apps tested work just fine from the Loupedeck device (BTT, Shortcuts, etc.). Only kmtrigger:// URLs are apparently not working.

@peternlewis is there a way to view all kmtrigger:// requests received by KM?

As KM's debugger/engine log only show when specific macros are triggered by a URL, seeing all incoming URL requests could help identify if the URL requests are being sent by the devices, but are not matching a specific macro due to encoding, etc.


Yeah, it's gotta be the Stream Deck. Probably.

I know this because the bug just bit me this morning, and the only change I made was to update the Stream Deck software and firmware. Hotkeys work but kmtrigger:// does not.

The reason I say "probably" is that when I run kmtrigger:// from Chrome I also see this permission check:

Maybe Stream Deck is running into the same issue but doesn't have the interface to ask?

This bites. I've probably got 50 macro triggers in my Stream Deck.

Except that it also occurs with other devices (see post directly above). I also did not get that confirmation dialog for other apps triggering KM macros via URL (e.g. Alfred, BTT, etc.), so I'm not sure that the lack of a permission check points to definite cause.

Users have reported that KM URLs work again after downgrading to an earlier version Stream Deck's software (v5.0), if you don't want to rebuild your button actions.

1 Like

Thanks for the tip! Found v5.0 here and it worked. You saved me from a very bad day.

What was absolutely killing me was I only updated the Stream Deck today because I was seeing something pretty flakey..which turned out to be a programming error on my part. Oy..

1 Like

No, there is no logging for that. Keyboard Maestro responds to the request (if it gets a request) with various error codes.

Maybe Script Debugger can see the events? I'm not sure if it can do that or not.

Are the error codes output to KM's debugger/engine log? Is there a specific error code when a kmtrigger:// request doesn't match a macro?

Is "Script Debugger" a component of KM or some other app?

Thank you.

No, they are responses to the AppleScript.

Script Debugger is an application, but I don't know if it can monitor the AppleEvent messages or not.

Script Debugger

I'm not aware of a method to make Script Debugger monitor live Apple Events from another app, but that's a question for Mark Alldritt and/or Shane Stanley on the Script Debugger Forum.


1 Like