String-triggered macros don't seem to work in Yosemite

I haven’t been able to get any of my string-triggered macros to work for any of the Yosemite betas, including the most current GM betas. Does anyone else have issues? Is there a fix/workaround?

e.g. "if this string is typed ‘xyz’, do these steps…"
I type the string and the macro is not triggered.

You need to ensure that Keyboard Maestro and Keyboard Maestro Engine are in the System Preferences ➤ Security & Privacy ➤ Accessibility settings.

Keyboard Maestro and Keyboard Maestro Engine, since version 6.2, both poke the system immediately on launch to make sure it knows they need to be in the list, and then the system prompts you to enable them.

Unfortunately, in the Yosemite GM builds (but, I believe, not in previous Yosemite betas), Apple broke something such that Keyboard Maestro Engine (and some other apps) are not properly added to the Accessibility panel.

To resolve this, until Apple fix it (they are at GM3 already, so who knows what they are doing), try control clicking on the Keyboard, select Show Package Contents, then drill down to the Contents, Resources folder and you’ll find the Keyboard Maestro file. Unlock the System Preferences, Accessibility panel and drag the Keyboard Maestro in. Make sure Keyboard Maestro and Keyboard Maestro Engine are listed and checked. That should hopefully resolve the problem.


I was able to follow all the way until you said to unlock the System Preferences. I am not seeing any way to do that from the Apple / System Preferences window nor the Accessibility window. I went into Accounts and unlocked that but I still can’t drag Keyboard Maestro file into the Accessibility panel.

Are you referring to a folder or file in the System Library or someplace else?

I am running GM build 3

  • Stephen

Unlock the System Preferences (bottom left of the window).

Either I am looking at the wrong window or I don’t have that lock option. In my last post I mentioned the only place I found that lock was in System Preferences / Users & Groups.

Here is where I am looking…

Under the Apple Menu I select System Preferences…

There is no lock anywhere to be found, just rows and columns of icons.

If I click on the Accessibility icon I see a row of items on the left but again, no lock icon.

Is there a preferences someplace to disable seeing the lock icon? I am running under an account with admin rights (the only account on the computer other than Guest User).


The lock icon appears only in some system preferences, including the Security & Privacy system preference.

Thanks, makes much more sense now that I know to look in Security & Privacy


For what its worth, Just installed Mavericks…oops I mean Yosemite. I was fortunate to have all the accessibility settings transferred with no problems. My KM string-initiated macros work fine as well.

Although my last post about finally seeing where to make the change was hopeful, when I actually tried to drag the Keyboard Maestro Engine into the page, after first unlock it, it does not get added.

I found the following post which describes the exact same problem with some other (evil) software.

Anyone else having trouble seeing or adding what is needed to the Security & Privacy Accessibility page?

. . . Stephen

Hmm…I did already have both of those active in the privacy/accessibility pane. I then deleted them, re-added them, and rebooted, and the strings still aren’t triggering.

Any other ideas?

Unfortunately, this is all bugs in Yosemite (some that also existed in Mavericks, though Yosemite is much worse).

Keyboard Maestro and Keyboard Maestro Engine need to be in the System Preferences ➤ Security & Privacy ➤ Accessibility list, and must be checked. If they are, and it is still not working, restart. This was all you needed to do in Mavericks. Unfortunately, Yosemite is buggier and has trouble even getting the applications into the list.

Basically your available options are:

  1. Ensure you have only one copy of Keyboard Maestro on your Mac or any mounted drive.
  2. Restart.
  3. Reset the accessibility permission system.
  4. Unlock the system preferences and manually drag the application in.
  5. Copy the Keyboard Maestro to your Applications folder, and then manually drag the application in to the accessibility list.

The Keyboard Maestro can be found by control clicking on Keyboard, choosing Show Package Contents and drilling down into Contents / Resources.

If all of that fails, then your only remaining option is to complain to Apple.

These directions helped, though there was some differences.

As soon as I coppied the Keyboard Maestro Engine to the Application folder, it showed up in the system pref, security area. I did not have to drop it into there manually from the copy in the Application folder.

Do I need the Keyboard Maestro Engine to be both in the package content and the Application folder?

. . . Stephen

No, I think you can safely delete the copy now - preferably empty the trash to ensure there are not two copies.

Note: According to the Many Tricks folks, it may be that once the Keyboard Maestro Engine is dragged in, it is actually working, it just does not appear in the list. Can you confirm that it was actually not working until you copied the Keyboard Maestro to the Applications folder?

Hi Peter,

I’m so glad i found this thread here. I was having exactly the issue described here.

Just in case the steps from above or from here dont fix the issue, like it was in my case, this were the steps which did it:

  1. Open the System Preferences ➤ Security & Privacy preferences.
  2. Switch to the Accessibility settings.
  3. In the Finder, control click on Keyboard, and choose Show Package Contents.
  4. Drill down into Contents / Resources and find the Keyboard Maestro
  5. Switch back to System Preferences.
  6. Click the Lock icon in the bottom left and enter your admin password.
  7. Drag the Keyboard Maestro into the list (the KM engine won’t appear yet - dont worry).
  8. Copy the Keyboard Maestro to /Applications (now the KM engine appears in the list).
  9. Trash the Keyboard Maestro from /Applications (the KM engine is still in the list - yay - but the strings are still not triggered).
  10. Empty the trash.
  11. Restart KM.

Then it worked.

The method from Alex worked for me as well, strange though it is.

I am running OS X 10.10.1 and KM 6.4.7.