Sudden failure of Keyboard Maestro in Sigil

I use Sigil to write ePubs and HTML code. I created 24 macros that worked fine until today when all of them failed. KM works fine with other applications. I quit Sigil, restarted, tossed out Sigil’s Library files, reinstalled Sigil, and still couldn’t run macros. I did an in-depth search and trashed every file related to Sigil such as playlists. No help.

I downloaded a new version. Now, I have partial functionality. Only 3 macros work. The triggers are F7, control-8, and control-S. The other 21 don’t work, though some use function keys and many use control-# or letter.

Any ideas on how to fix this?

If a macro “does nothing”, the first thing to try is the Help ➤ Assistance window. Select Something expected is not happening and then follow the instructions and see if you can trigger the macro.

Then you'll know whether the issue is with macro group activation, with the trigger, or with the actions.

I discovered that the problem was more widespread that Sigil. Every macro with text input (typing or pasting) does not work in every application that has that type of macro. Replacing KM did nothing. Making a new (not a duplicate) macro solves the problem. I suspect that a file in the Keyboard Maestro Application Support folder became corrupt. I will retrieve that folder from a backup and swap it. If the backup works, then I’ll know it was a corrupt file.

Greg Tetrault

Replacing the Keyboard Maestro application rarely solves any problems. Replacing the Keyboard Maestro Application Support folder rarely solves any problems, and often causes problems unless the ownership and permissions are correctly restored.

It sounds more like an accessibility permission problem. If you recently upgraded to Mojave, this is even more likely: You will have to ensure you enable Accessibility for both Keyboard Maestro and Keyboard Maestro Engine. If you have any troubles with accessibility (eg typing keystrokes), try toggling the accessibility permissions for Keyboard Maestro and Keyboard Maestro Engine off and then on again.

Since I removed all KM files and installed a clean copy of KM, the ownership and permissions are correct. (I checked.) This is a bizarre problem with macros failing only if they have an input text action. Accessibility settings are correct, which is why all other macros work. I have made no changes to my computer, and the failure was sudden. Is there a file in the OS that controls text input that could be corrupt?

  I have a spare drive, so if I can't find the problem, my next step is to perform a clean install of OS El Capitan and then a clean install of KM. If that doesn't solve the problem, I will surrender to gremlins.

Greg Tetrault


I installed a clean copy of El Capitan on a blank drive. I then
installed Keyboard Maestro. All the input text choices worked. It
appears that something failed in my original El Capitan system. I don't
want to move to a new drive, so I'd like to replace the System files
most likely to be at fault. Any suggestions?

Greg T

Hey @GregT,

What version of Keyboard Maestro are you using?

What version of macOS are you using?




I don't see how the versions matter. KM was working completely one day, and then it was only partially working the next.

Greg T

Hey Greg,

You never know what users are doing unless they tell you. Sometimes the versions matter.

It's very rare that this happens without the user having changed something, so the first question should always be “Did I change or install something that might have caused this problem?”

You said you didn't, but I've said the same and then realized later that I did and had forgotten.

The most common thing that causes an app's Macro Group to stop working is the user accidentally turning disabling it and not realizing they did so.

The second most common thing is that an app update can break Keyboard Maestro's link to it in the its Macro Group. In this case the easiest solution is to:

  • Make sure the app is running.
  • Go to its Macro Group.
  • Change the app assigned to it to something unrelated.
  • Change the app assigned to it back to your desired app.

I just tried Sigil 0.9.10 on my macOS 10.12.6 system and didn't have any problems associating a Macro Group and Macros to it.

Macros that paste to it work fine.

If you want to post your macros that are failing I'd be happy to test them.

It's usually a good idea to create a new user on the existing system before taking this step.

Have you tried booting into your Recovery Disk Partition and repairing the drive?

Are you running any utilities on your Mac besides Keyboard Maestro?

There's a lot of troubleshooting that can be done, but you can sure waste a lot of time doing it...


Doing this showed that KM had no problems on a clean system while
using the KM folder from my original setup. That proves that the
problem was not KM or the macro files. It is likely that one or
more files in a Library folder or the System Folder went bad. I
just don't know which one. If I had OS 9, I could figure it out,
but troubleshooting OS X is difficult. I'm now experiencing
intermittent slow downs, so I think it will be best to migrate to
the drive with the clean copy of El Capitan. That may be faster
than continuing to troubleshoot.

Greg T