Tab Key Conflict with KM

I have been using KM for some time, however very simple applications and commands. I recently started writing some AppleScripts and running through KM. Now I find there is some type of conflict with the tab key and KM. When tab key would not work, I tried removing all programs to test it, once I determined it was not a hardware problem. Now when I do not run KM, the tab key works. When I run KM, it does not. MacBook Pro 2020 running OS 10.15.6. Thanks for any suggestions what may be causing this. Ranny

So, it sounds like Keyboard Maestro might have the Tab key assigned to a Macro - if you are finding no problems when Keyboard Maestro is not running.

Maybe the first thing to try is to do a search in Keyboard Maestro for Tab

To put the tab in the search field of Keyboard Maestro you enter the glyph for Tab, (which is ) in the search field. Make sure you are searching all your Macros - so, are searching in the All Macros smart folder.

You can also put trigger:⇥ in the search field to narrow it completely down to triggers/hot keys.

That will list any Macros that have the tab key assigned as a hot key. If you find the one that is doing it you can give it another hot key or disable the Macro or just delete it if you are not needing it.

Hope that helps.


This appears to solve the problem. There were a couple of macros that I had tried and abandoned that had used the tab key. Once eliminated, tab key on normal keyboard works well. Thanks!!!

1 Like

Very glad. I've had so many people helping me on this Forum - nice to be able to help someone myself.


My Tab key has stopped working in numerous applications (except it does work in Microsoft Word).

I have determined this is related to Keyboard Maestro because if I quit KM then all is fine; when I resume KM the Tab key stops working again in the other apps.

If I add a few new temporary/test macros in KM with Tab as the hot key then I get a conflict palette which lists the new Macros – there are no other macros listed.

So it does not seem there is a KM Macro with Tab set as the hot key.

What else could be configured in KM causing this problem?

This solved it

I did not realize that to search for macros with Tab as the hot key you have to use the Tab glyph ⇥