Taking notes on a video

I have a project going where I download a video and want to take notes on the video in a file with the same name as the video, so they stay together in the folder I keep them in. I want to put some of the info in a form using some input variables.

So, I've looked at the KM Manual about Prompt for User Input and I can make that form come up for the purpose of inputting. Here it is.

200903 Setup Video Document Input 617

1st problem- I can't seem to type any info into the fields. For instance, the first field, Title. How do I transform the Title into a variable with this form?

Thanks!

I'm confused by your question that shows the Prompt for User input.
All you have to do is click in the field and enter the data.
See Prompt for User Input action.

Thanks! For some reason, I couldn't type anything into the fields. I have no idea why, but today it seems to be mostly working fine. EXCEPT the fourth field is URL. I've copied the URL from Firefox and inserted the cursor in the field. When I press paste, it prints not in the form but in the word processor that will eventually accept the variables along with other boilerplate.

So, I'm thinking that the macro should start out in Firefox, where the original data exists that I eventually want to put into Bean, which is where I assigned the Macro.

When I transferred the Input Form to Firefox, I discovered that typing the info in works fine, but when I copy the URL and Title and try to paste them into the fields, nothing happens at all. I don't see any sense in typing the Title or URL into the fields when I should be able to paste it in and then go to Bean to make the form.

Does that make sense?

Thanks!

Why is it that I can type into the Prompt for User Input action, but not paste into it?

I was intrigued to read about your problems given I've never heard anyone complain about anything similar in the past so I tried to reproduce them for myself.

This is the Prompt For User Input action I used:
KM 0 2020-09-14_22-58-34

and this is the result of running the action:
KM 1 2020-09-14_22-59-33

which shows that not only have I been able to type into the fields but I also pasted that YouTube URL into the final field.

I hope you can clearly see what I've done. However, I have no idea what you have done so why don't you post your macro here, for us all to see? Then maybe once we can see exactly what you've done we can provide some help based on something more than just the description you've given.

Thanks! The macro is very simple so far. The only real difference is the addition of the Trigger.

200915 Setup Video Document

I didn't put variables into the date fields, but type those in formatted as yymmdd.

My eventual plan is to gather these variables and use them in a word processing document to set up a form on which I can take notes and tags or keywords. Using the Title of the Video as the title of the WP document keeps the notes together with the video in the finder.

Usually the video comes from YouTube, either just now or at some previous time, so I have the page with the video on it and I copy the Title of the video and the URL. I use CopyPaste Pro, so I can have more than 1 clipboard available at a time. I insert the cursor in one or the other of the two fields and paste the appropriate clipboard and nothing appears in the form.

I am able to type the dates in their Fields just fine. In fact, I can type the Title and URL in just fine as well, but that is surely defeating the purpose. In fact, I have made macros saving the Title and URL to Named Clipboards in KM and if I Insert by Typing, instead of Insert by Pasting, the data appears in the form just fine.

Thanks again, for your consideration.

Well that tells me there could be some kind of interaction between CopyPaste Pro and KM that may be the root of the problem. I don’t use or know CPP so I can’t really help on that - maybe someone else on the forum can.

Edit: just searched this forum and I see you’ve had problems with CPP before. I suspect you know more about this issue than anybody else :wink:

1 Like

Thanks. I had forgotten about that episode with CPP. Probably because the problem just seemed to go away, so I didn't learn anything very much. Guess I'll have to see if CPP is effecting this macro.

Maybe I just need to simplify things by using one app instead of two even if I don't want to. It's a matter of loyalty and habit as much as anything. CPP was one of the first apps I used, before KM, even before QuicKeys, which I thought was fabulous...until KM blew it out of the water.

Well, that was a couple of years ago... and things by the sound of it resolved themselves a bit mysteriously. Have you tried repeating what you did then, but now? Like turning off CPP? Has CPP just had a major update?

Last update was January and that wasn't major. I've turned it off and going to make a run at only using KM for a while.

in System>Security>Privacy>Automation, check that KM has permission to control CPP

:+1: Thanks!