Text-Expansion Macro Not Working After Latest 10.0 Update

Updated to the latest and this is one of the issues I'm running into.

This worked fine before, but now, nothing happens...any suggestions?

I replicated your macro and it works fine for me on Keyboard Maestro 10.

Verify the following for us:

  1. Your accessibility settings (sometimes after an update you have to give KM access again)
  2. Your macro is in a macro group that is currently enabled (although it looks like it is from the screenshot, just double check).

Let us know about that and we can go from there.


1 Like

Another thing to do is turn on the Debugger, ensure that "Pause New Macros" is checked, and then try to trigger the macro. This will determine if the macro is being triggered or not. Cdthomer's items are possible solutions if it's NOT being triggered, but my test will determine if the problem is that the action itself isn't working.

1 Like

@cdthomer everything is on, thank you
@Sleepy "Pause New Macros" is checked as well, thank you

Not sure if this has anything to do with it, but this "Screen Recording Disabled" message shows after the update...

Screen Shot 2021-11-14 at 8.17.05 AM

Even after its clearly on...

I also deleted the macro and recreated it, and still not working.

The screen recording issue is pretty common. There’s a wiki entry about it I’ll see if I can find for you but in the meantime remove KM from that list and add it again. Then try your macro again.

1 Like

That did it! Removing it from Accessibility and re-adding!

Thank you so much!

1 Like

Oh great! Glad it was something simple and that it’s working again!

1 Like