Text Expansion Puzzle [Solved – macros were disabled]

Hello guys,

I have a very very weird behavior with text expansion. I didn't have that problem 6 months ago but since then I had a new mac with Ventura 13.1. My KM is 10.2.


Very very basic text expansions macros (3 separate ones):

if I type "emadsi" => it should expand my full "@adsixxx.com" address
if I type "emfle" => it should expand my full "@flexxxxxx.com" address
if I type "emgmail" => it should expand my full @gmail.com address

Now, I have really NO CLUE why: ONLY the first one will work...

Even deleting the 2 others and recreating them from a duplication of the working one will NOT work, which is pretty mind-blowing.

Any idea?

Thanks a lot,

Probably this is not much help, but two things come to my mind

  1. is there another text expansion app active?

  2. "recreating them from a duplication". Have you tried rebuilding everything completely?


Without seeing the actual Macros it is only possible to give some troubleshooting ideas. Could you upload an actual Macro (and image of that Macro) that doesn't work (with your email as some other text)?

A bit of advice with Text Expansions. As "ema" could be the beginning of typing a real word you are having to make a long string to make the trigger unique. If you start (or end) your text expansion trigger with a double letter that would never be typed in a real word (such as "qq") you can make your triggers much shorter.

For example I have a text expansion which types my whole address and just has the trigger qq9

The gmail email address might by triggered by something like qqgm

1 Like

OK thanks all for the tips, it was dumber than I thought...

I had these 2 macros in my "all macros" group... but they are actually inside a disabled "for-new-mac" group that contains the old macros I used in the past and wanted to re-import... so if I don't put these in the global macro group it's not gonna work!

1 Like

@Zabobon is right, as almost always, when he says that the strings should not occur "in the real world". Your strings (triggers) seem problematic to me.

If you (like me) don't like these prefixes "qq", then try simpler suffixes, if you want. I use space, space at the end of the strings. This does not occur in the real world either, at least not in mine :slightly_smiling_face:

space, space after a word is the default Mac/iPhone method of adding a period/full stop so, that would throw me :rofl:

Really? I didn't even know that. Apparently I have become old :woozy_face:

1 Like