Text Reformatting no longer works

I just noticed that my text formatting (make selected text all caps, sentence cap, lower case, etc) macros no longer work. I don't know if this happened with the switch to KM 9.0.3. I am running Mac OS 10.12.6.

Is there a fix for this?

I don't know of any text processing issues with KM9. Please upload your macro so we can help diagnose the issue.

Here is the macro is question. Note that I have several other ones for each of the formatting styles I want to use (...all caps, sentence cap, etc). Each has the same trigger, so that it calls up a palette that allows me to choose the one I want (and as of now, none of the macros work...).

lower case Macro (v9.0.3)

lower case.kmmacros (2.4 KB)

Try adding a brief Pause step after the Copy and/or before the Paste; experiment with the length to see if that fixes the issue.

Adding pauses does not fix it. I had tried that earlier.

When these macros were working before, there never was a pause included in the macro.

And I forgot to mention - I get this message: "Macro Cancelled. Action timeout exceeded. Macro "lower case" cancelled (while executing Copuy.)" This message pops up whether or not I have inserted pauses.

Again, these macros used to work perfectly before - I can not figure out why they are not working now.

Anyone have a fix??

That means the COPY Action timed out while trying to copy the selection.
What are you trying to copy? From what app?

Try using your macro on simple text in BBEdit or TextEdit.

BTW, what is the purpose of your last Action?

I don't think you need it.

The macros do not work in ANY application (they used to before). Even selecting just 2 words of text in TextEdit will not work.

The last action is to clear the clipboard of the copied text.

Then something very strange is going on with your Mac, and/or your Macro.

Are you sure that proper macro is being triggered?
Try adding a Notification Action at the very top to confirm.

Also, try using the Help > Interactive Help wizard in the KM Editor app. When it opens choose "Something expected is not happening..."


My version of your macro's Filter action (which works without problem) is a little bit different. See the "to: Source" option:


1 Like

That is a rather pertinent detail. That means that the copy action, which works by simulating a ⌘C and waiting for the system clipboard to change is failing because the clipboard is not changing. In all likelihood, that is because the simulating of the ⌘C is failing.

My first guess would be accessibility permissions, but 10.12.6 is so old I don't even remember if it had them, and it predates the bugs in Mojave’s accessibility permissions (unless Apple has back ported those bugs!), so if that was the issue Keyboard Maestro should be alerting you to the problem.

mrpasini - your version did not work

peter - I have checked the Accessibility Permissions and they are enabled for both the KM app and the KM engine. In fact, I had previously quit KM completely, removed the permissions, restarted KM and then re-allowed the two KM items. Still no luck.

And I have not changed anything on my system - why would this problem suddenly start now? My other macros seem to work fine...

Then look at your Copy command, as Peter suggested. Open the Clipboard History Switcher, execute a Copy command in the application that is causing a problem and see if your selection is actually put on the System clipboard.

Have you tried restarting your Mac altogether?

Also, just curious why you're still on Sierra. Maybe consider updating the OS if possible.

Yes, I had tried restarting the computer...

It turns out there is something wonky in my account - if I make a new account, the macros work fine. The problem now is figuring out what the problem item is - doing a Safe Boot does not solve the problem, so it is something else.

Right now I have gotten around the problem by replacing the "Copy" command with a "Simulate Keystroke" command (command-C). A kludge, I know, but I don't have time right now to figure out what is causing the original macro to break...