The "Open a URL" action is not functioning

The same link( lang:zh-cn)
using the "Open a URL" action, prompts an invalid response.

I tried percent encoding the URL, and it opened “” directly.

The URL must be valid. I suggest you turn on the Notify on Failure in the action if it is not already as that will report the issue.

For the URL to be valid, you need to ensure the SystemClipboard token is properly URL quoted, otherwise the URL will be invalid. You can use the Filter action and the Percent Encode for URL filter to encode the clipboard. The rest of the URL cannot be encoded as that would encode parts of the URL that are not meant to be encoded.

1 Like

Thank you for your help; my issue has been resolved.

Here's a screenshot for reference for users who encounter a similar problem:

Specifically, the effect is that :
if the current browser is Arc, it opens a link with parameters using Arc:
Otherwise, it opens it using the Chrome browser.

Of course, it would be even more convenient if KM supports opening URLs directly in the currently active browser.:smile:

1 Like

Something like this? :wink:


No, I was searching for the keyword "url" before, so I didn't see this action! Thank you for pointing it out.

Additionally, it seems that this action has a bug:

After trying this action in the Arc browser, it didn't work. It still opened the URL in Chrome (which I set as the default browser). but It worked in the Safari browser. @peternlewis

Fixed for the next version.

Arc is not a supported browser.

Keyboard Maestro only supports browsers that have solid AppleScript support compatible with either Google Chrome or Safari (if a browser had solid AppleScript support in an incompatible way, I would consider adding support for that browser, but I don't know of any browser like that).

So Front Browser (from Keyboard Maestro’s point of view) is the most recently used Chrome-like or Safari-like browser.