Trying to Activate Menu Item in Photos App

I'm trying to trigger this menu item in Photos:


With this action:


Result: Can't find target menu item. Not sure why it's not working? Is there a workaround?

Hey Rick,

  • What version of macOS?
  • What version of Keyboard Maestro?


Did you use the Menu popup (upper right of the Action dialog, i.e. your second image) to choose the Menu item? It would likely pick up any hidden characters.

1 Like

This has come up before in this Forum and I’ve had it too. I.E. Photos has some sort of Menu bug that sometimes prevents some of its sub menus working as expected with Keyboard Maestro.

It seems to particularly affect user-created photo albums.

I am away from my computer right now and writing this on an iPhone. But I think the solution was to invoke the main menu and then select the sub menu by having Keyboard Maestro type its name followed by Keyboard Maestro simulating the Enter Key.

I will have a proper check later and upload a real example if it’s helpful.

Does adding a small delay - to give the submenu a chance to appear - help? You would probably then need a combination of arrow and character navigation.

KM Version 9.2
macOS Version 11.6.1 (20G224)

No, that was one of the first things I tried: no help.

Yes, I tried to set up the menu click action that way. It lets me select down to the Albums submenu, but no further. Interestingly, The Albums submenu shows a > symbol, indicating it should expand further, but hovering on it it does not reveal further submenus:


That's the workaround I used in the end. In this case after it gets to Albums, it's down arrow twice, type the beginning of the menu item name, then Enter. It works, but it could be broken later by changes in the names and order of other user-defined albums.

Thanks for all your input folks.

Yes, it’s definitely a Photos bug as I had exactly the same issue with Albums named by myself.

1 Like

I don't think it's a bug per se. I think it's a logic/implementation problem they failed to account for and that needs to be fixed.

Apple has changed the way the menu is displayed and broken the accessibility relationship between the parent menu object and the child menu object.

I'm testing with BBEdit which has a similar issue in its File › New menu, since I'm using Mojave and can't test with Big Sur.


1 Like