Trying to Solve Blocked Keyboard Shortcut in Other Apps

TL;DR: Several keyboard shortcuts stopped working in other apps on Mac. Surprisingly, Keyboard Maestro still has access to them. I'm trying to understand why and fix the problem everywhere else.

For the better part of a year now, two keyboard shortcuts have been unavailable on my Mac. They are ⌃⌥⌘C and ⌃⌥⌘T.

  • ⌃⌥⌘C is regularly used to do advanced copying in apps, e.g. in Mailplane it copies a link to an email message, in DevonThink it copies a link to an item, and in Byword it copies the selected text as rich text.
  • ⌃⌥⌘T is the keyboard shortcut that I have, for years, assigned to "Open TextExpander."

About a year ago, I could no longer use or assign these keyboard shortcuts. Other shortcuts, e.g. ⌃⌥⌘F and ⌃⌥⌘B, still work.

I'm sure something is blocking access to these keyboard shortcuts. I have no idea what. To my surprise, Keyboard Maestro still has access to them, so I created macros in Keyboard Maestro, triggered by these "hot keys," to perform the actions they should be able to perform.

Does anyone know 1) why these shortcuts would be blocked elsewhere or, at very least, 2) why Keyboard Maestro still has access to them?

As a data point, Key Codes does not recognize either ⌃⌥⌘C or ⌃⌥⌘T when pressed. It does, however, recognize ⌃⌥⌘B.

Upload your macros then we can figure it out what's wrong in it.

Use <kbd>⌘</kbd>, and the forum web will show this:

AppleScript will recognize every key on your keyboard, learn more on

If there are some keystroke KM can't recognize, use Karabiner Elements to help KM:

Thanks for the reply. I've uploaded an export of of my macro library. (I'm hoping that's what you were looking for.)

<kbd>⌘</kbd> is just cool! Thanks!

Finally, a point of clarification. Keyboard Maestro seems to be the only thing on my Mac that IS recognizing these keyboard shortcuts. I don't believe there is a problem with Keyboard Maestro at all. What I'm trying to figure out is 1) why would Keyboard Maestro work when everything else doesn't, and 2) knowing why Keyboard Maestro works, maybe figure out why TextExpander's preference won't recognize ⌃⌥⌘T and a bunch of other apps that natively use ⌃⌥⌘C don't recognize it as well.

Global Macro Group and Other Macros.kmlibrary (1.3 MB)

You might need/want to try something like KeyCue that will show you what keyboard shortcuts are available.

(There are several apps like KeyCue out there, but I've found that it seems to be the best at finding the most global keyboard shortcuts.)

It's not cheap, but I think it has a demo, which might be sufficient.

Upload the macro/macros which have the keyboard shortcuts stop working problem, not all your macros.

Thanks, TJ.

Again, I should mention the Keyboard Maestro seems to be the only thing that IS working. I'm hoping that if I can figure out why it does work, I'll discover why other apps don't. I'm using Byword as an example below.

I installed the trial of KeyCue. It sees the "⌃⌥⌘C Copy Rich Text" shortcut:

However, when I press that combination of keys nothing happens. (Typically menu items will cause the "File", "Edit", "Help", etc. menu items to highlight while pressing the keyboard shortcut. This doesn't happen when I press ⌃⌥⌘C .)

When trying this, I've closed every open app and menubar app with the exception of the following, because they don't have a "quit" option:

I'm assuming that something else must be intercepting the command, BUT Keyboard Maestro can still see it. FWIW, I don't have any shortcuts enabled in the Keyboard System Preference pane:

I'm baffled and hoping to understand why Keyboard Maestro can trigger when ⌃⌥⌘C is pressed. Here's the work around I engineered:

Copy Rich Text.kmmacros (2.1 KB)

Any thoughts are greatly appreciated!

Can you please go into Preferences for each of the affected apps and verify nothing in there is having an effect?

Then confirm that nothing in System Preferences > Keyboard & Mouse > Keyboard Shortcuts has been checked/unchecked

Beyond that, you may want to check your key bindings, though it would seem odd that anything changed there:

Let us know

Working through the specific example of Byword, the only preferences are as follows (none of which seem to be causing the problem):

As I mentioned before, there are no keyboard shortcuts assigned in System Preferences > Keyboard > Mouse & Keyboard Shortcuts.

I also don't have any keybindings set up. The "KeyBindings" folder in the following path doesn't even exist: ~/Library/KeyBindings/DefaultKeyBinding.dict

It does seem related that ⌃⌥⌘C doesn't work in every application on my system that wants to use it. It's almost like something more globally is blocking it, though nothing is listed in KeyCue as "blocking" it.

Nevertheless Keyboard Maestro has access to this "hot key". Any ideas what I should try next?

OK, that is odd.

The other think I would try in your place is a macro that only works in your app that types the keys

My guess is this would not work, but...

After that I would get into deleting Library files, uninstalling and reinstalling apps...

Thanks for the input. You are correct that that does not work.

I've tried reinstalling Byword, but since it effects so many apps (Byword, DevonThink, Mailplane, etc.), I'm guessing that it's not an issue with this app, but another app.

Let me add one more wrinkle to this. I just created another user account, logged out of mine and into it, and the same issue is happening. I'm assuming this tells me that it's a system level issue.

I have a sneaking suspicion that command+option+control+C is used by macOS for something at a system level , but I don't know what it is.

I did discover that Spectacle uses that shortcut for 'Center' but I assume you aren't using that app, and it wouldn't explain why it wasn't working on a new account.

That's a good hunch, and your guess is right, I am not using Spectacle. I'm completely stumped at this point.

That is not surprising to me as it is the expected behavior of KM.

  • KM HotKey Triggers will OVERRIDE all App Keyboard ShortCuts that are the same keystroke
  • However, if the macOS or another App has a HotKey that is the same as a KM HotKey, then the results may be unpredictable:
    • Both KM and the App may respond
    • KM may override the App

See KM Wiki Hot Key trigger:

Hot Keys will override application menu Command Keys or any other keys typically used in applications, but if any other application registers the same hot key, then both your macro and the other application's action will happen.

:warning: Note that whether or not a key typed by Keyboard Maestro itself will trigger a hot key (and thus be swallowed and execute a macro) or not (and thus go through to the application is not defined - either behaviour may happen and which behaviour happens will vary depending on many unpredictable factors.

I also have a KM Macro in a Global Macro Group triggered by the HotKey C. I have been using this for several years without any problems.

When I disable this Macro, then that keystroke works in some apps (that specifically support it), and I get the "boing" sound in other apps indicating there is no action set for this keystroke.


I have scanned all of the above posts, and believe these are new suggestions. My apologies if already tried/answered.

  1. First thing is to eliminate KM from the picture.
    • Stop the KM Engine
    • Quit the KM Editor app
  2. Also stop/quit all Services and Apps that provide a HotKey service like KM.
    • For example, DevonThink and/or its developer provide a number of services named "WordService:..." that use a number of hotkeys.
  3. Now test the shortcuts in apps where they are supposed to work.
  4. If they still don't work, then double-check the Mac System Preferences > Keyboard > ShortCuts to make sure you have not set the keystroke somewhere.

Safe Mode Testing

Finally, if nothing else works, then you may need to startup your Mac in safe mode , then launch ONLY one app at a time which use the shortcuts that have not been working.

  1. Test each app with it being the only one running.
  2. If all the shortcuts work, the open one app
    1. Test
    2. Continue to add more apps, one at a time, and test the shortcut in the original app

This should identify the app that is causing the issue.

Good luck, and let us know how it goes.

Thank you so much! I've figured out the culprit Logitech Options.

I booted into safe mode, tried exactly what you said, and no luck. Then, in a moment of insight, I copied all of the process from Activity Monitor in safe mode to a text file. I rebooted and copied all the process from Activity Monitor while not in safe mode to a text file. I then compared them in excel. That narrowed the possible culprits to just a few, which included Logitech Options. I uninstalled Logitech Options and presto, the keyboard shortcut came back.

Now, I need to do some more digging but at least I have a direction. Thanks a MILLION. This has been driving me crazy for ages.

1 Like

So I have been trying to figure out if I am having issues due to keyboard maestro and logitech options not getting along together! I am not able to assign keystroke commands to my mx master mouse in the logitech software anymore now that I have downloaded keyboard maestro. Do you know of a way to solve this issue? Thanks!!

1 Like

About a year ago I encountered major problems with the Logitech Control Center, as have many others. Subsequently I uninstalled and my mouse continue to work fine. This also enabled KM to see the mouse buttons as USB Device Keys.