Turning off beeping sound on volume macro


#1

Running 8.0.4. I’ve got a simple Volume Up macro:

Triggered by F19 (on a Mac USB extended keyboard)
Will execute Increase System Sound Volume.

It works, but it also makes an unwanted alert sound each time I push F19 (which gets louder as I increase the volume). I’ve turned off all Sound Effects in the Sound System Preference.

Oddly the Volume Down macro (with F18) works silently, as I want it to.

Any ideas?


#2

I have no idea why you are hearing the alert sound, but most likely due to something wrong in your macro. You will need to post your macro for us to provide more help.

However, this macro works fine for me, with no sounds for either up or down:


#3

Here’s the noise-making macro (apologies, didn’t know about exporting and uploading).

I’m wondering if this noise is produced by KM when there’s an error. It doesn’t seem to be a Mac System Preference sound.

Volume Down.kmmacros (1.4 KB)


#4

There is nothing wrong with the macro. There must be something else reacting to the F19 key. Try disabling the macro and press F19 to see what happens.

Are you using any other keyboard utilities (BetterTouchTool, ControllerMate, Karabiner, etc) that might be responding to F19?

Curious why you are using KM and F18/F19 to change volume when the Apple Extended keyboard uses the F11/F12 buttons as volume down/up hardware keys.


#5

Criminy. I can’t believe it took me this long to figure this out. It was Dictation (System Preferences: Keyboard), which was turned on (even though I’ve never used it in my life) and the shortcut was F19.

Thanks all for helping solve this, been bugging me for over a year.


#6

Try not to wait a year to solve any problem, asking here will often get you a very quick solution to almost any issue.