Type a keystroke: option+Command

I use Keyboard Meastro to cheat with shortcuts in my EMR at the hospital. The most recent update changed the keystroke to get into the menu toolbar. Previously I used a keystroke option+command+C. But now I need to drop the C and use only option+command. I can't seem, to get KM to recognize that keystroke. It seems to need a character with those modifier keys. Tried several workarounds, but no luck. Tried recording a macro, but it won't acknowledge I'm doing anything when I only hit those 2 keys together. Any advice?

It might not solve your actual Macro, but Keyboard Maestro does have an Action called Press and Hold Modifier Key. If you click on the yellow warning triangle it gives some tips to getting it to work. It seems it will release instantly the Macro moves on, so you need to add in a Pause.

But if you are just trying to open a Menu Item in your App, you might be better off using Keyboard Maestro's Select or Show a Menu Item Action. There is info about that here:


If neither of those two things lead to a solution you will need to give some more information and upload your existing Macro with a Screenshot and name the App you are trying to automate. Without that information, guessing what you are exactly trying to do can only go so far :grinning:

As @Zabobon says, ⌘ and ⌥ are modifiers to keystrokes rather than keystrokes themselves. I'd try, in increasing order of desperation:


...and finally:

The "Press and hold" and "Release" options can be found in the "Type Modifier" action's cogwheel menu.

I was worried that without a keystroke there'd be nothing to modify, but "Press and hold Option" works fine in Terminal, changing the standard I-beam cursor to a cross, so I have hope...

Perfect guys. Problem solved. Thanks!!