TYPE hot key trigger does not work

I am trying to type the key for a hot key trigger. Keyboard Maestro says “Type” and then I type a key and nothing happens. I cannot create a macro .

I have looked at the following

  • The Keyboard Maestro Engine is running

  • Accessibility is enabled (for the editor or the engine)

  • Secure Input Mode enabled----I do not know how to do this

I am running Parallels and 1 password and quit them both but that did not fix it .

I appreciate help with this and what to do next.


Welcome to the forum, drsoram!

Some more info would be helpful.

  • Have you written a macro and are attempting to assign a Trigger key for it?

  • Can you show us a screen image?

  • What Trigger key are you pressing?

Sounds like the Mojave Accessibility Permission Problem bug.

You will have to ensure you enable Accessibility for both Keyboard Maestro and Keyboard Maestro Engine. If you have any troubles with accessibility (eg typing keystrokes, selecting menus, copy/paste, etc), you need to toggle the accessibility permissions (System Preferences, Security & Privacy, Privacy, Accessibility) for Keyboard Maestro and Keyboard Maestro Engine off and then on again.

Thank you @peternlewis !!! That fixed it ! I did just what you said with keyboard Acc permissions and it worked!


1 Like