UAD Console Volume Control - Keystroke Not Working

I'm trying to automate a volume change in the UAD Console mixer application. The hotkeys cmd+f11 (volume down) and cmd+f12 (volume up) work when manually entered, but not when triggered by Keyboard Maestro's "Type a Keystroke" action. I'm just wondering if anyone might have an idea why that is and whether there's a workaround.


Hey Neil,

You're trying to use a keyboard hardware key with Keyboard Maestro?

That generally doesn’t work.

You can directly control volume with Keyboard Maestro.




There are text tokens and functions related to volume as well.

And AppleScript can control volume settings:

set volumeSettings to get volume settings

if output volume of volumeSettings ≠ 50 then
   set volume output volume 50
end if

See the volume settings in the StandardAdditions.Osax dictionary in Script Debugger or the Apple Script Editor.


1 Like

Thanks for the suggestion, but those actions don't seem to do anything, most likely because I'm using an external audio interface which overrides System Sound controls. Still, you've saved me some time scratching my head!

I've manged to get it working by using an approximate click and drag on the mixer UI.

Thanks again! :slight_smile:

1 Like

I tried the exact same thing with the same result as you. Checkout this software, it allow you to control your UAD interface with midi:

If you don't want to use midi you can always use keyboard maestro to send midi and trigger however you want from there.

Funnily enough I did actually buy it! Works great! Great minds think alike.