UI Browser Lives Again!

The code for UI Browser 4 was released, which was a kindly gesture – unfortunately for now, it doesn't really work.

However, I have discovered a way to get UI Browser 3 to work. Before sharing this, however, I should get the go-ahead from @peternlewis. (Peter, what do you think?)

The developer of UI Bowser, Bill Cheeseman, posted this in the Script Debugger forum.

I’ve not tried it and would be somewhat surprised if it ran on Sonoma.

More information here:

And here:

1 Like

Thank you - yes, true. You can still download the software - you just can't purchase or register it. I've found a way around that, but won't post unless I get the go-ahead. Normally that wouldn't even be plausible, but I noticed he open-sourced version 4, so he may simply want people to be able to continue using it - but isn't maintaining it, so is simply not selling it. I don't really know.

It's not great with Ventura, but it works well enough to use, fortunately. :tada:

I'm not following why you need my permission?

In that case, you would need the author’s permission (and I would not condone posting ways to break protections on an app on this forum without the author’s permission).


Got ya, and glad I asked. I'm seeing now that Bill posted the work-around himself on the MacScripting forum. So…if anyone wants to still use it, head over there - that would be the place.

If Bill posts a way to use v3, and he's happy sharing that, then you can share the same information here.

1 Like

Can you post a link please?

I assume that's the one.


1 Like

No - I know about that Rob. I mean the link to the Ventura fix on the MacScripting forum.

Oh, sorry. That's the only "fix" I'm aware of, and it's also linked above in the post directly from Bill. UIBrowser3 seems to run OK on my Ventura Mac—what's the issue?


No idea - ask @notsteve as he posted that there was an issue... my UIB v3 seems to work fine on everything I have but I assumed there was something I hadn't noticed.

I think he was trying to refer to the "unlicensed but unpurchasable and demo expired" problem without directly referring to it, in case it violated the forum's rules?


Post #5 would indicate otherwise to me, Rob but then that may be just me...

Hi guys, I'm using UI Browser (UIB) 3.0.2 on a MBP M2 running Ventura 13.6.2. I have found that UIB works well enough, but crashes occasionally. @tiffle, was there something specific that you're finding problematic?


I recently upgraded to Ventura and haven't yet tried my purchased version of UIB3 on it so when you said

it sounded like you had found a fix on the Macsripter forum so I was asking you to provide a link to save me the hassle of searching for it. That's all. I'm not at all interested in version 4 of UIB (yet!).

I've tried Bill's script and it fails to find the 561201.padl file.

Any suggestions?

Hmmm…I’m not sure what file might be. What OS are you in?

Oh, you’re saying your OS here. That is a strange error message - what are you doing right before the message occurs? (E.g., installing, running, setting security permissions, etc.)