"Unable to Find Application Named Logic Pro"

Anyone ever encounter this? I'm getting an error whereby KM can't find Logic Pro, even though it's currently running.



What happens when you click the Reopen initial windows checkbox?

No change, i'm afraid.

Upload your macro and I’ll test from my end.

This happened to me a while ago with a different app (can’t remember which) after some updates happened. I got rid of the problem by deleting the Activate action and re-inserting it. Maybe that might work for you?

Hey Neil,

The result window you show if from a Text-Script.

What's the script?


@kcwhat Thanks!! Here you go:

Low Latency Monitor Toggle.kmmacros (103.0 KB)

@tiffle That was the first thing I tried, to no avail unfortunately.

@ccstone As you can see from the macro, there's no text script, so I'm stumped.

Oddly, I get the same message even if I disable all actions except for "Activate Logic Pro". Very strange, given that it has worked perfectly for about six months until yesterday.


Look in the log for that error, and see if there's any useful information nearby.

~/Library/Logs/Keyboard Maestro/Engine.log

Did you change anything on your system yesterday?

Try changing Logic Pro to a different app – pause long enough for KM to write the change – and change it back.

If that doesn't work try replacing the action altogether.

Have you rebooted?


Ok I feel awfully silly. Is there a sheepish emoji? Ah yes. :see_no_evil:

I was triggering it from my Stream Deck and it was actually triggering a parent macro that already included actions at the top and bottom to take note of and then activate the starting application, which were unneccesary. Not sure why I'd added those in there but as you can see, I've disabled them and it's working fine now.

Sorry to waste your time and I thank you for your kindness in trying to help me out!!

For good measure: :see_no_evil:

Yeah, that's a big palm-smack all right...  :sunglasses:

This is one of the dangers of using sub-macros and one reason I seldom use them.

IOW – I've made this mistake myself and cost myself a significant amount of time debugging.

Sooner or later I'll probably establish a method of turning a macro-level debug mode on/off that displays the call-chain of any sub-macros.

Although I wouldn't be surprised if @DanThomas or @JMichaelTX have already done this somewhere.