Unable to Turn on Allow Javascript from Apple Events

I'm a little lost as to whats going on here. I have keyboard maestro running perfectly on my own machine. I'm trying to get it setup on a work computer. I'm using TeamViewer to remotely login to this computer, trying to click

View > Developer > Turn on Javascript from Apple Events

When I click this it doesn't seem to do anything. No checkmark appears next to it as it does on my machine. I've checked the version number of chrome and it's the same as what I'm running on my machine. Not sure if me being on a remote desktop matters, but thought I would include that.

Any suggestions to make it possible to turn this on? Or anyone know what could be preventing it?

Just a guess: Disable all Chrome extensions on your work Mac and try again.
Have you done a restart of Chrome and your work Mac?

Yes, restarted Chrome, restarted the work mac. No luck on disabling extensions and trying again.

I did find someone mentioning issues trying to click this same button in Safari via Remote Desktop. Going to wait until someone in the morning can try and click it themselves, just hoping that it will be solved with that.