Using Keyboard Maestro variable in ‘Execute a Script in Terminal’ action (plug-in action)

I am trying to use a Keyboard Maestro variable in a terminal action (not shell script action), but it does not seem to be working as expected. I am using the $KMVAR_name syntax. Does it work only on shell script action?


You can paste your KM variables to the second text field (“KM variables”)

Thank you for the reply! The plugin is not quite working though; almost possible that I am not using it properly!


This is how it looks at the moment.

I am on Keyboard Maestro 9.0.4, like this comment was made when Keyboard Maestro 8 was in use. @Tom, would you know if the plugin is supposed to work on Keyboard Maestro 9? If it is, any clues on what I am doing wrong?


Just tested it and it works still fine here with KM 9.0.4 on macOS 10.15.2



No, not really ATM. Are you using any “special” (uncommon) Terminal settings?

Thanks, Tom! I had to quit the Keyboard Maestro engine from File > Quit engine and launch it again. It works now.

Oh, yes, if you updated from an older version of a plugin you likely have to do that. Or just make Editor and Engine reload with…

tell application "Keyboard Maestro" to reload
tell application "Keyboard Maestro Engine" to reload


Great that it works now.

1 Like