VMWare Fusion / Excel: Need to Change Settings?

I’ve searched on ‘vmware’ or ‘fusion’ and didn’t find a similar question.

I’m using VMWare Fusion 8.0.2 and KM 7.3.

I’m starting a macro with the first step to see if KM works in Fusion with Excel. The macro is attempting to ‘Goto’ a cell which is either the F5 function key or CTRL+G. Neither one brings up the Goto box as the first and only keystroke in the macro.

I’ve tried the keystrokes shift+dn and this works.

Is there a setting within KM or Fusion that needs to change in order to create working KM macros in VMFusion in Excel?

Thanks for any assistance you can provide.


I don’t have VMWare Fusion, so I can’t offer much in the way of suggestions for this.

Emulators, virtual machines, and games often work at a very low level which can be below the level that Keyboard Maestro works at. As such, what works and what doesn’t is very difficult to known, and can easily change from version to version, and based on a variety of settings.

Virtual Machines often have different modes that they can run in, and often some of the modes will work better for this sort of thing, so that instead of the emulator trying to play lots of games, it just accepts keystrokes as normal and translates them. But you’ll have to look at your VMWare settings to figure that out.

Hopefully others who have VMWare Fusion might be able to offer more advice. And you could perhaps look for a VMWare Fusion forum and ask there.


Thanks for the response. The basic keys work:
• arrows (up, down, left, right)
• alphanumeric characters.

When I place a function key or the home, end, page up and page down key at the beginning of the macro they won’t execute unless I place a pause before the key.

Thanks again and hope to hear from anyone with experience with VMWare Fusion. I’ve asked the quesiton on the VMWare Fusion forum but received no responses.


1 Like

Not quite an answer to the original question, but your suggestion helped me fix a longstanding headache: VMware now has an option in VM/Settings/Keyboard// :radio_button:/Edit Profile/Key Mappings which helped solve my biggest wish, one of the few things in life Keyboard Maestro couldn’t do for me: Mapping a key on the numeric keypad to tab (which is a nuisance when reconciling in Quicken).
I seemed to need to kill the Keyboard Maestro engine while defining the shortcut. I also seem to be having some success with mapping F4 (the old Paste Key) to cmd-V.