Voice Control Not Working But HotKey Does

Hey guys, I've finally reached the point where I'm out of ideas and am hoping someone here has a suggestion.

I've been working on automating a number of my systems, one of them being a way to read web articles while I'm doing other things. I've found that "Ghostreader Plus" works the best for me.
Now I'm trying to set up a system that closes Ghostreader via a voice command/hotkey. To do this I've set up a hotkey linked to an applescript in KM, as well as the voice control system that's built into the mac. The problem is, it seems to work fine if I press the keys manually, but nothing when I speak the command phrase. At best it'll transcribe the spoken keyphrase in Ghostreader.

I've tried both the per-determined "Quit" hotkey that's built into Ghostreader, as well as one that I chose, same result. Does anybody have any ideas on where the problem is or how to fix it? Assuming it can be fixed. I really am confused on this one.

Here's the applescript that I've been using:

activate application "GhostReader Plus"
tell application "System Events"
tell process "GhostReader Plus"
click menu item "Close" of menu 1 of menu bar item "File" of menu bar 1
click button "delete" of sheet 1 of window "Untitled"
end tell
end tell