Why can't I set a hot key for macros?

I just downloaded and used KM, and I find that I cannot set hot key for new Macro ! How can I do this? When I type the shortcut, nothing happens, as shown in the figure

1 Like

How to solve this problem? Thanks!

All you should have to do at that point is press your desired key combination.

Do you get a system-beep or something when you try?

What keyboard shortcuts have you tried?

I get no feedback when I try.
I randomly tried any key combination and it didn't work.

You have relaunched KM Engine?

(Keyboard Maestro > File > Quit Engine; Keyboard Maestro > File > Launch Engine)

I tried this method, or it didn't work. I even restarted my mac, uninstalled and installed KM, and it didn't work.

Are you on MacOs Catalina?

Yes.!How can I solve this problem?

Make sure you aren’t having permission issues.

Read this post.

Let us know if this corrects your issue.


Thanks, I successfully solved the problem.
Accessibility general:
You probably do not need to restart, and if things are still causing problems you can use the Terminal “tccutil reset Accessibility” command to reset the Accessibility permissions, then Restart, and then try the whole process again.

Good deal.

Thanks for your help!

Just adding that I had the same problem. Oddly strange that I couldn't type a new Hot Key, but could enter text anywhere else in KM fine. The solution - as described in the links here - was going to System Preferences->Security & Privacy->Privacy->Accessibility and then turning off and then back on the Accessibility settings for Keyboard Maestro and KM Engine that solved the problem. MacOS 10.14.6 KM 9.0.5.