Alert Sound When Editing a Macro

Since updating to El Capitan, every time I change anything in the KM Editor (e.g., deleting or adding a character in an AppleScript text script) I immediately hear an alert sound. There must be some way to turn this off, but I haven't been able to find out how. I tried turning off notifications for KM Editor and Engine in the Notifications preference panel, but that didn't help. Does anyone have any suggestions?


Did some further checking on my alert sound problem. Found following error message in KM Editor log associated with the alert:

2015-10-25 10:06:54 ERROR: Preference shared sync write failed

So I went into KM preferences and unchecked the Sync Macros check box. Then re-checked it and selected the existing sync file which was in my Dropbox folder. No more errors in the Editor log and no alert sounds when I edit a macro. Weird!


Did your username change? If so, the path to the sync file will have changed which would be the problem.

No, still using the same username.

I just had the same error. Constant alert sounds whenever I clicked in the editor and had no idea what was causing it until I came to this thread. Then I looked in the editor log and indeed found the error:

Preference shared sync write failed

disabling and reenabling sync file solved it.

I really think that a warning of sort should appear in the editor to indicate the it is now, it's quite difficult to guess where the problem is coming from.

And if the sync file or the path to sync file is corrupted/lost the consequences could be quite annoying for anyone using the function. So the sooner the user is warned the better. Thanks.