Always hide palette "Enabled"

Hi there, I'm trying to control a window resize app (Rectangle) with a hot key enabled group of key remappings (so I can use common keyboard shortcuts).

It's basically: Maestro hot key > remap common short cut (e.g. ctrl + down arrow) to rare short cut which I set in the Rectangle app. Then hit the common short cut and it should resize whatever window is in front.

But the window in front is always the little "Enabled + Maestro Group Name", which then dutifully gets pushed around.

Is there a way to never show this palette window and to stay focussed on the window that's in front?

PS: I am aware that there's a build in "Move and Resize Windows" function, but it lacks a few presets and I'd like to use the other app.

Thanks in advance!

Hi Menta, welcome to the forum.

I can imagine roughly what that looks like, and I am sure that there will be an easy solution. However, the details of how you have implemented your macro are a little ambiguous. If you can post your macro here, that will help get you the most useful answers. See How to Post/Upload Your Macro to the Forum to find out how to do this.

Resize Left.kmmacros (2.2 KB)

I hope this worked. Here's a screenshot of one of the actions too.
Screenshot 2024-05-28 at 08.58.49

And this is the trigger for the whole group.

Screenshot 2024-05-28 at 09.00.41

Thanks for the details. Since you are not explicitly using palettes, the palette you see will be a conflict palette. These appear when the same trigger is being used for more than one macro or macro group.

Conflict palettes can be a very useful way to be presented with a choice of macros from the same trigger, but they are not what you need here, and so you need to find which other macro or macro group also uses your chosen hotkey (⌥Down Arrow). Change that, and the conflict palette will no longer appear.

I hope that I have understood the situation correctly and that that will fix things for you.

In case it's of interest, I will also mention the following.

I use the window manager Moom. For most window operations, I have set use a unique hotkey within the app, but I also a global hotkey to enable some other hotkeys. This is all done within the app, so does not require KM, but it's the same sort of idea as you have with your macro.

It seems that equivalent functionality may be available within the "Pro" version of Rectangle.

Both apps are cheap, but I appreciate that you may actually prefer to use KM as much as possible! :slightly_smiling_face:

Thanks for the tip, but it doesn't seem to be a conflict palette (where multiple macros are listed). I always get this little overlay when activating a macro group with a short cut.
Screenshot 2024-05-28 at 20.28.38

1 Like

Oh, I see. Well to get rid of that, you just need to:

  1. Select the macro group in the editor to see its settings.
  2. Make sure that "Display when toggled" is not checked.

There doesn't seem to be an option to unselect it (like here for example).

Probably because I run an ancient version ( 7.3)? I recently upgraded from an 2011 MBP (R.I.P.) and am afraid to touch all the stuff under the hood...

That version was released about 9 years old, so an update to KM might indeed be overdue. Otherwise there is that option of using Rectangle Pro to replace your macro, if it seems suitable.

I'm sure someone else will comment soon if they have a greater insight into what's happening with your macro.

Updating worked like a charm, the annoying little pop up is gone.

Props to the developers that an upgrade from 7.3 to 11.0 works flawlessly (and also that an ancient version still worked with Sonoma).

1 Like