Bug - KBM9 Clipboard History does not recognize copies from Notes.app

First - nice upgrade, overall, but...

here is a strange one… since upgrading to KBM9, KBM will not read the clipboard for anything coming from the Notes.app (Mojave 10.14.6).

I have the clipboard history switcher open, I copy text from a note, and nothing shows up in the clipboard history switcher. I copy anything else - email, files, folders - and they show up in the clipboard history switcher.

I’ve tried different notes. I’ve tried different copy methods (cmd-c, right-click, menu)… nothing. Also, I've confirmed that I have no excluded apps in the KBM preferences under Excluded.

This is affecting a macro that used to work in KBM8.

Possibly the same issue as described here:

The concerned apps:

I can confirm that behavior.

@peternlewis: FWIW, LaunchBar does properly register the clipboard set by Notes. Just tested it.

Running Keyboard Maestro 9.0 & LaunchBar 6.11.1 (6209)
on macOS 10.14.5 (Mojave)

Confirmed for me too—I hope this gets fixes soon!

OK, v9 changed such that if there was an error in any flavor, then it would fail to read the rest of the clipboard. Apparently there is always an error reading the dyn.ah62d4rv4gk81n65yru (an old styled text flavor) in Notes, and for Mail it is dyn.ah62d4rv4gu8y4znmkfwgk6xfsr3za2pxsvw0e55bsmwfk8puqy (an old style of MUIAddressPasteboardType). The old version covered up this error.

I have fixed this for the next version, which should be out soon (maybe a week, depending on various factors). If you want to try, you can avoid the flavor using:

defaults write com.stairways.keyboardmaestro.engine ExtraIgnoredClipboardFlavors 'dyn.ah62d4rv4gk81n65yru|dyn.ah62d4rv4gu8y4znmkfwgk6xfsr3za2pxsvw0e55bsmwfk8puqy'

I think that would resolve the issue in Notes and Mail, but there are probably other erroring flavors.

1 Like

The copy functionality returns, but now the Paste menu seems to be disappeared from my KBM menu bar icon. I’ve only recently discovered the clipboard feature, so maybe my expectations are off. FYI, just in case.

Which Paste menu?

Shouldn’t I see Paste, here?

I don’t on my MacBook, where I ran the command you shared. I do on my iMac, where I have not.

Assuming you have enabled the Paste menu (in Keyboard Maestro’s General preferences), and assuming the clipboard history has some text items, then yes, you should see the Paste submenu in the Keyboard Maestro status menu.

"Include Paste in Status Menu". I missed that one. Thanks. All looks OK, now.