Bug report: iOS app flips upside-down

This is amusing, at least. When you launch the iOS app the first time, it flips upside-down. If you switch away and back, it is in the correct orientation.

My device - iPhone 8 Plus, iOS 11.0.2.


What iOS app?

“Keyboard Maestro Control”

Oh, yeah, it opens upside down. Funny.


And UI-wise it seems it hasn‘t been updated since iOS 4 or so. On my venerable 6s Plus it displays like on an iPhone 3. Not that I care that much, just an aside.

Amazing, as long as I’ve been using KM, I was unaware of the KM iOS app.
As much as I know about KM, there is so much more that I don’t know.
what a real treasure house! :smile:

Downloading it now.

1 Like

You’re joking, right? You won’t tell us you didn’t know of the famous Keyboard Maestro iOS app, right?

Well, just tried to do something with it, and I had to force-quit it because it froze.

But, basically, I think it’s a great app. [I hope nobody will be angered by the slight sarcasm of this and the previous posts ;)]

Roger that. One more thing you know that I don’t, Tom. :wink:

I just tried to connect, and it fails.
Very frustrating. After failure, you just get an error code, and you loose all that you typed in the connection screen.

@peternlewis, this is very low priority for me, but if you make any updates to the iOS app may I suggest that you allow the user to enter and save a connection setup, whether or not it fails.

I have the KM Web server running on my Mac, with a username and PW, and with the iOS app checked. But I can’t connect. I have no idea why, or how to troubleshoot this. The KM Wiki needs to be updated with a lot more specific information.

1 Like

It seems in this (exceptional) case you haven’t been missing much :wink:

Your KM web server needs to be running.
KM > Preferences > Web Server > toggle on Web Server Enabled
set a username and password
Make sure “iOS Access Enabled (requires username and password)” is on

It’s a decent way of triggering Macros on the local LAN but it doesn’t work across routers*

  • unless you expose the web server to the internet and I really don’t recommend that.

If you do, make sure you have a good password and use only the HTTPS port.

Yeah, basically it’s a decent app. I was just mocking about the fact that the display still isn’t up to iPhone 6s Plus (2 years ago or so), and that the app completely stalls when trying to connect to an inactive host.

As I noted above, I had already done all that. Still no joy.

Did you enter the port number explicitly?

I used the Bonjour advertised host and it connected no problem with my username/password.

Sure? I just set up the KM server on my MBP and could connect immediately.


You have to enter the name of the host as displayed in System Preferences > Sharing. I left the port at the default.

OK, that's different. I was using "localhost".

But still no joy with:

Any ideas?

To be sure click on “Edit”:

In my case “alice“ as well as “alice.local” works fine.

I will add a +1 to this. When you can connect, the app does its job, and is very valuable to me. But it needs some love, plus some UI updates.