Can't Disable Sync'd Macro Groups Due to Identical MacUUIDs


I’m syncing my macros between a MacBook Pro and a Mac Pro. From what I understand from your documentation, each machine should have a unique %MacUUID% for the “disabled on this mac” feature to work.

The weird thing is these two machines spew out the same UUID so that my macros sync just fine but I can’t disable some macro groups on a specific machine. Sure their hardware UUIDs are different, only KM’s MacUUIDs are the same.

I migrated data from Mac Pro’s time machine backup to my MacBook Pro. They have different %MacName%s.

I tried uninstalling and reinstalling from scratch on both machines but no joy.

I have two other iMacs with the data migrated from the same time machine backup. Their %MacUUID%s are different. Only this MacBook Pro has the same %MacUUID% as Mac Pro’s.

What could have gone wrong?

It should be a kludgy hack, but here’s how I finally sorted it out.

$ defaults write com.stairways.keyboardmaestro.engine MacUUID ‘some value different than the other’

Now they have different MacUUID’s and the ‘disabled on this Mac’ feature works just fine.

Not sure if it’s the right way to fix it though.

Maybe this can be of some help?

Cheers ヅ,

Bill 
FaceBook: Redirecting...

Sunday, October 11, 20158:37 PMr

That is pretty much the correct solution.

Basically, the issue is that Keyboard Maestro's preferences have been copied from one Mac to the other, so as far as it can tell its the same Mac.

Probably the simplest is to quit Keyboard Maestro and Keyboard Maestro Engine, and then do:

 defaults delete com.stairways.keyboardmaestro.engine MacUUID

And then launch Keyboard Maestro and it will create a new UUID for the Mac.

1 Like