Can't sync or save new macros Mac os 10.15 Catalina - Caused by Antivirus System

I am getting errors when I try to create a new macro. with beeping noise as I type. It will not save the macros I enter. I also can't create a new macro file.

I checked perms in system prefs and made sure KM has access in accessibility tab, as well as full disk access.


Please see:

TIP: Resolving Catalina (and Mojave) Accessibility and Security Permissions Issues

Unfortunately this does not work.

  1. I toggled both app and engine. no change
  2. I deleted them, restarted app, added back -- no change
  3. I deleted app, deleted app support folder in library, reinstalled re toggled - no change
  4. I ran tccutil at user and sudo prompt and retoggled in accessibility - no change

I can't create a new macros file
I can't even create a new macro. When I click to add one, I get a mac alert tone. Nothing entered is saved.

Seems to be really corrupted.. is there a post about how to entirely wipe the install and start with a clean slate?

I went a step further.. used AppDelete to wipe it out entirely.
With a fresh install, I was able to enter a macro. But when I tried to sync macros with a new clean file in a local directory I get this error

Failed to start syncing macros.
The attempt to start syncing the macros failed (%@)

I been syncing KM for years now, and never a problem.
IAC, you pick a folder to put the sync file in, which KM generates. You don't pick a file.
Just to be sure, I'd pick a folder with no files in it to test the sync.

finally found the issue.. it was stupid antivirus.
Bitdefender for Mac has a "safe files" option. This locks down parts of the disk. I had to add the app back to this whitelist to allow it to write to the kmsync file. ugh.. can't believe I forgot to check antivirus.

1 Like