Click Google Chrome Link on Chromium

Hello Guys,

im using Chronium as Browser and unfortunatly KBM only supports Chrome or Safari with that Action even though Chronium supports Applescript. Is it possible to do the same action with the Macro executing Apple- or Javascript?

How would the code look like? Im really grateful for your help!

Have you tried adding Chromium as a "targetable" browser, following the instructions in the "Browser Used In Actions & Tokens" part of the manual's "Preferences Set by Command Line" section?

1 Like

I havent. I just read through it but i dont understand it.

I also saw this Post Change Default Browser Macro (v9.0.5), which i think is the solution, but i have no clue how i can adapt the Macro to the Chronium Browser.

Do you have any advice for me?

Do you want it to be KM's "default" Chrome-based browser, and so the one that is targeted by the Chrome-related Actions, Tokens, and Functions -- or do you just want to be able to use it with those for "Front Browser"?

For the first, open Terminal and:

defaults write com.stairways.keyboardmaestro.engine AppleScriptGoogleChromeBundleID -string "org.chromium.Chromium"
defaults write com.stairways.keyboardmaestro.engine BrowserGoogleChromeName -string "Chromium Browser"

For the second, have you already added extra browsers? You can check with

defaults read com.stairways.keyboardmaestro.engine AdditionalWebBrowserBundleIDs

...which will return a "does not exist" message if you haven't. You can then add Chromium

defaults write com.stairways.keyboardmaestro.engine AdditionalWebBrowserBundleIDs -string "org.chromium.Chromium"

If you have already added additional browsers then you'll need to take the list from the first command and add Chromium to it. So if your first command returns


...because you've already added the Opera browser, you would write

defaults write com.stairways.keyboardmaestro.engine AdditionalWebBrowserBundleIDs -string "com.operasoftware.Opera,org.chromium.Chromium"
1 Like

Wow you are amazing. Thank you for your help! It works now

That's actually some Grade A luck -- it was untested because Chromium refuses to install for me, every download being flagged as damaged...

Glad it's working!