Copy and paste into Word 2016

I’m trying to write a macro to copy and paste from Accordance (the Bible software program I use) into Word 2016. When I paste into Word, I want to set the font to the standard Greek/Hebrew font I use (SBL BibLit for those in the know) at 12 point (my standard font size for writing). I’ve tried the macro below to do this and failed—I have the font size set at 16 point in Accordance (my age means my eyes can’t read it at 12 point!), and when I run this macro, the text pastes into Word at 16 point without changing the size. Any wisdom on how to solve this please folks?

Paste to Word
Triggered by any of the following:
The Hot Key ⌃G is pressed
Will execute the following actions:
Apply Style to Clipboard
Set font to SBL BibLit.
Set size to 12.
Sample Text
Activate Microsoft Word
Notify on failure.

Hmm, does it happen in every font? Like instead of the SBL would it happen in Helvetica? And I’d be curious to see if you tried a larger size (like 20) or another smaller size (like 4) would the same issue happen, because it’s tough to tell which aspect of the Style you’re applying is the culprit.

Thanks Kevin. I’ve just tried changing the macro to set the clipboard (System clipboard) to Helvetica 20 point, and it still pastes as SBL BibLit 16 point! I tried earlier to copy to a specific named clipboard (which I called Temporary clipboard), format on that clipboard, and then paste from that clipboard, and it made no difference. Is this a bug, do you think?

Possibly, what you might want to try is to filter the clipboard first by using the Remove Style filter, that should make the clipboard plain text, then try to style the plain text. So to test do the Remove Style filter then just paste that into like Text Edit and see how it turned out and if it worked then style that how you want.

Something like this

Because it seems like the application your copying from might be the source of the dilemma so removing all the styles from it may solve the problem.

Hey Steve,

It works for me, although I don't have your specific font to test with.

Did you remember to check the checkbox in the action?

Many people miss that step.


Thanks Kevin. I tried that and I’m still getting just the 16 point version of the text, which is v frustrating. Any further ideas?

Hey Steve,

Have you tried putting a brief pause after the Apply Style to Clipboard.

You may not be letting the clipboard catch up before your paste action which will result in the original text being pasted.


I’ve tried a pause of up to 10 seconds and it makes no difference. Aaaargh!

Okay. Post your macro, so we can test.

What version of OSX?
What version of Word?
What version of Keyboard Maestro?


Here's the macro. I'm working in OSX 10.11.3 and using Word 2016 v 15.19.1 and KM 7.0.3.

Steve, the first thing that jumps out at me is that you should be using the “System Clipboard”, and therefore the normal “Copy” and “Paste” actions.
Also, can you post the actual macro file?

Try this manual process:

  1. COPY from your Bible app
  2. PASTE into TextEdit as a rich text document
  3. Select All, and apply the font settings you want
  4. COPY from TextEdit
  5. PASTE into Word

How does it look?

Thanks Michael. I followed the process you described, and the result was that the word looked as I'd want: SBL BiblLit font and 12 point size. What does that mean?
I'd tried the macro using the System Clipboard and had the same result as before—the font was correct, but the size was 16 point (the size it is in the display of Accordance, my Bible software) rather than 12 point. That's why I'd tried using a named clipboard.
Here's the macro (I hope)
Keyboard Maestro Actions

Keyboard Maestro Actions.kmactions (2.6 KB)

Steve, there is no benefit to using Named Clipboard in this case, so I'd suggest you change it back to "System Clipboard". I have seen some unexpected behavior with Named Clipboards.

As a test, could you try changing the font in your KM macro to Helvetica 12, and run the macro.

Also, when you paste into a Word doc, you should see a popup at the bottom that has options for:

Do you see this? If so, click on it and see which choice is selected.

Thanks Michael. I’ve edited to move back to System Clipboard and just used ordinary copy and paste.
Changing to Helvetica seems to make no difference: it still pastes in as SBL BibLit 16 point.
Word 2016 has a slightly different view of the paste-in menu you show, and none of the items is checked.

Hey Steve,

I’ve replicated your problem with Word from Office 2011.

Quit fighting with it, until I’m able to confer with Peter.


I just tried this sequence of actions and it worked fine in Word 2016. I installed the font and it seemed to work fine with varying sizes. So I'm not sure what's going on on your Mac at this point.

Keyboard Maestro Actions.kmactions (2.3 KB)

Hey Steve,

I did what Peter did but hours ago, and I had the same problem you did.

So I’ve been messing with it and writing a bug report for Peter – all to NO avail.

His macro works.


He didn’t forget to change Default Clipboard to System Clipboard.

Somehow my mind likes to synonymize those two (and I’m not the only one).

Default Clipboard is a user-named clipboard and has NOTHING to do with Keyboard Maestro defaults. (Mistaken.)

Edit 2016/03/04 18:20 CST:

Keyboard Maestro creates a named clipboard called Default Clipboard that is DIFFERENT than the System Clipboard.

This is very confusing and has caused many people problems over time.

It is likely to disappear in a future update to Keyboard Maestro (post version 7.0.3).


1 Like

Yep, I’ve had the same problem, and posted about it some time ago.
IMO, the “Default Clipboard” should be either renamed, or removed.

Just reading the words, “Default Clipboard” and “System Clipboard” mean the same thing to me.

And, KM also has a “Current Clipboard” as a KM Token.
Why is that? Why isn’t it called “System Clipboard”?

The KM Wiki is no help. It says:

The %CurrentClipboard% token returns the text of the current clipboard.

Sorry, this is all off-topic. We should start a new topic on “Clipboards”.

Folks, Thanks for your efforts. I'm now using the same macro as Peter, and I'm still getting the problem. I've set the clipboard to filter as System Clipboard. The macro is below. I must be doing something wrong—any further ideas, please?
Keyboard Maestro “Paste to Word” Macro

Paste to Word.kmmacros (4.0 KB)