Corsair keyboard with extended "G" keys... some sleuthing

Hi Peter. First: thanks for 8.2 :smile:

You were kind enough to help get the 18 “G” keys going on my Corsair keyboard, but a firmware update pretty much messed it up. Since then, while I could use the G-keys, it was odd. (So odd, that I bought another keyboard, and used a third-party device for my macros.) But today, on a whim, I thought I’d try it with KM 8.2.

Let me explain “odd” - let’s say I assign G9 to a simple “paste” macro. If I single tap G9, it works. If I tap 2 times, it works; but after the 3rd tap, the key quits functioning (being recognized?) for up to 40 seconds. Or, if I tap G1, G2, G3… the whole G-key keypad goes away for 40 seconds.

Not suitable for quick, repeated use of macros via the G-Keys.

Here’s what I discovered today, however, and it seems an important clue: if I follow a G-key tap with a tap on -any- key that’s NOT on the keypad, the 40-second wait goes away. I could to 20 pastes in a row, for example, by tapping:
shift… etc

So, I created a macro with was “paste” “shift” (using type a modifier)… and it worked!

I cannot tap as fast as a simple command-v will allow, but the 3-limit, 40-second delay is gone.

I’m sharing this for two reasons:
First, in case it gives you an “Aha! Moment” and an idea how to fix it.
and Second: for the benefit of any other Corsair users who have experienced the same thing.

I’m going to yank my “new” setup (new keyboard/and external keypad) and return to my beloved keyboard with the g-keys. All I need to do is add the type-a-modifier-key to each of the assigned short cuts, and I’m back to work.

FWIW, and YMMV :wink:

What is the trigger? USB Device Key?

I'd guess the driver is doing something stupid, but it's hard to say.

Sounds very bizarre to me.

Yep: USB device key. Perhaps it’s waiting for some acknowledgement? I don’t know enough about the internals… when a key is hit (“normal keyboard key”) is some bit set somewhere in the OS that indicates the keystroke has been recognized, or acknowledged? Is there a difference between “key down” and “key released”? Perhaps something is waiting for such, and the limit-of-three is a roll-over artifact? It really seems to me that some kind of waiting-for-something is going on, if for no other reason that if I wait long enough, the wait ends. It’s like a queue finally clearing out.

And it’s apparent that it’s only the USB Device Key that is susceptible to it. Like I mentioned, tapping a “regular key” clears the situation instantly.

OK: I’m picking at straws here. Just thought this might provide some kind of clue. If I’m the only one seeing it, then I’m good with sticking a shift-key press at the end of each macro, as that seems to clear it up.

With the USB Device Key trigger, Keyboard Maestro just watches the events on the Human Interface Device system, and looks for value changes where a bit goes on (pressed) or off (released).

So for whatever reason, the bits are not being set or cleared.

My guess is the device behaves somewhat differently one way or the other, maybe it never sends the cleared bit.

Unfortunately the Human Interface Device specification is extremely permissive, the device can send pretty much whatever it wants on the assumption that some device specific driver will figure it out and do something. Meanwhile, Keyboard Maestro, can only work in the most generic of ways and hope that the device sends values that are vageuly sensible.

Thanks for your patient explanation, Peter. Makes perfect sense to me
(and it’s kind of nice that this old programmer’s brain at least
speculated in the correct ball-park!)

It is what it is, and having discovered the technique of sticking in a
phantom keystroke at the end of my G-Key macros is easy enough to live

Best wishes,


Hi, would it be possible to share Peter’s ‘tips’ on getting the 'G’keys working?
I have a K95 also and would love to get them going.


Actually, there’s nothing special you have to do: they work. What’s unusual is that when you add one of the G-Keys, you they all look to be the same key: “Corsair K95 RGB Gaming Keyboard #2” (or that’s what I see.) (There was once a time when the actual key showed up, but no more.)
Despite the fact that they all -appear- to be the same key, they are not, and each G-Key works fine. So just go thru adding your macros, and hitting whichever G-Key you want, and ignore the bogus name.

I also ran across the issue in this thread, in which repeated presses of any given G-Key failed quickly. The solution was to end each macro with “Type the Shift Modifier”.


Don’t known what I’m doing wrong but none of them are showing up :frowning:

Are you selecting them as “device key”?


No, I was using the ‘hot key’

I’ll have another go tonight, I’m a total noob with this software (only installed it last night)

In the “triggered by” popup, choose “this device key”.

That should do it for you. (previous comments apply…)


Can’t wait to get home to test it out!

Thanks Tracy @tvalleau

Still no dice :frowning:

Not sure what’s happening (or isn’t) but it’s almost like none of the “G keys” are being recognized.

Any suggestions?


Best I can do is show you what my setup looks like. If that doesn’t
help, your problem is beyond my pay grade.

Here’s a screenshot:


Thanks Tracy,

Yeah I can't get anything to come up in that box (from the G-Keys).
Are you using any other software?
*Note I'm using ckb

Thanks for your help

Nope… just KM


Ah OK, I saw your post in the GitHub-ckb forum and thought that you might have.

A firmware update fixed the issue, now all 18 G keys are recognized!
Just need to spend some time reading through the forum learning how to get the most from this software!

Thanks for the USB Device Key trigger trick, I would never have thought to use that.

1 Like

I should have thought to suggest firmware… but I’m glad you’re running
now! :slight_smile:


Does anyone have a Corsair K95 keyboard with Catalina installed? I would like to know if Keyboard Maestro displays the right button name for USB Device Key triggers when they are configured in Catalina.