Razer Keyboard Extended "M" (Macro) Keys and "This device key" Trigger

Hi, Peter and Forum Members,

I bought a Razer BlackWidow Chroma V2 mechanical keyboard in 2018, and while I like the keyboard itself for its clicky response, Razer's software has always been a pain in the -- keyboard.

And then Razer completely dropped Mac support and upgrades to its lousy software. :rage:

Luckily, the keyboard works correctly as a keyboard, but without color customization. I don't care.

But the 5 "M" macro keys are useless -- unless I can get KM to recognize them.

I've searched the Forum and reviewed tvaileau's "Corsair keyboard with extended 'G' keys" post ([Corsair keyboard with extended "G" keys... some sleuthing]
For the Razer keyboard, using "This device key" as a trigger, KM recognizes regular keys as, for instance, "Razer BlackWidow Chroma V2 F1," but there's no response at all in KM when I hit an "M" key.

Is there a way to get KM to recognize those keys?

Thanks in advance,


Did you try using only the hot key trigger or did you also try using the USB Device Key trigger?

Another idea: if you can reprogram the device keys (on Windows) then I presume the reprogrammed values (to USB keys) will be usable on Macs.

I'm just an average person here. Sometimes my advice isn't right.

Thanks, Sleepy.

My default Trigger is "This hot key," which does not recognize the "M" macro keys.

I also tried "This device key" as a trigger, as above. At your suggestion, I tried "This USB device" which does nothing.


I have much older Razer mechanical keyboards (I should sell them now) that also have M keys on the far left hand side. I don't use it currently, but IIRC I had to play around with the "Use F Keys as function keys" setting in macOS system preferences to get it the M keys to work properly without needing to hold the fn key simultaneously. Have a play with that, see what you can work out.

I'm pretty sure you could redefine the M keys using the Razer Synapse configuration app which would then permit KM to recognize your M keys. But if you don't want to do that, that's fine.

Thanks, vincent_ardern.

I think you're talking about the "Use F1, F2, etc. keys as standard function keys" option which DOESN'T appear in my System Preferences > Keyboard.

An Apple support document says "If you don't see 'Use F1, F2, etc. keys as standard function keys', you might be using a keyboard not made by Apple."

While in System Preferences > Keyboard, I tried to see if M keys would be recognized for a Keyboard Shortcut.


Are you still using the Razer keyboards, and are the "M" keys working?

Actually, I prefer to use KM for key substitutions -- as all the substitutions, etc. are in one place.

But tell me how.


Thanks, Sleepy.

What "Razer Synapse configuration app" is that?

Razer's MacOS software is kaput in Big Sur.

Go to google, search for "Razer Synapse 2.0 supported devices", the first result should be the download page where you can download their keyboard configuration app, and they do support Big Sur. Why do you say that they don't?

I couldn't send the link because that site seems to change all links to some session tracking link. I don't like passing links that have trackers in them.


Thanks for the link, but this is the Razer Synapse software that's no longer supported.

And believe me, I did everything to try to make it work when I upgraded to Big Sur.

And, Razer announced that it was no longer supporting MacOS.

If you look at the download link you recommended, it reads, "Download Synapse 2.0 for Mac OS X 10.10 - 10.14."

NOT Big Sur.

On the other hand, are you using Razer Synapse or other Razer software with a Razer keyboard, on Big Sur? I'm on the most recent version, 11.5.2?


@KMfan tried if Karabiner can configure it?

I didn't notice that version range. Sorry, pal. I didn't realize they might discontinue support so I didn't look at the version numbers.

But there is still a point to be made. If you can find an older version of macOS then you can re-program the M-keys keyboard (using their software) and the keyboard will remember its new configuration which would then carry over into a newer macOS. Remember, most smart keyboards and mice have memory to store what their keys and buttons mean.

I programmed one of the obscure buttons on my Steelseries mouse (years ago) and whenever I accidentally press it now, it goes into an infinite loop of sending USB keys to my computer, and the only way to stop the mouse is to unplug it for a second then plug it back in. I tried downloading the software yesterday to fix that, but I don't think it runs under Monterey. We can't blame vendors for not having software versions for Beta OSs.

Thanks, Sleepy.

Hello, Hello.

My question was about using Keyboard Maestro to utilize these "M" keys, and I'm not likely to mess with these keys any further if KM can't do it.

But you brought up Karabiner -- is there a reason to use Karabiner in addition to KM?


no, unlikely. Went again through the thread and looks like all possibilities have been explored.

I will get back to this over the weekend

Thanks, vincent_ardern.

So my device is an RZ03-0038 (not 0038x, which seems to be the 2014 version). Mine has 3 level (plus breathe mode) blue LED lighting, not the 2014 green, or chroma lighting. Mine also conveniently has a macOS layout which seems to have been discontinued not too long after 2013. I think mine was only ever known as "Razer Black Widow Ultimate", and then the later models had other designations (like 2014 or Chroma) but those designations weren't always used in publications because newer models superseded older models. All of which is to say that YMMV, as things might have changed slightly on the firmware for later keyboards - I don't know to be sure.

I have the "Use F1, F2, etc. keys as standard function keys" in keyboard settings checked (enabled) and the top row of keys currently works to do their labeled accessory functions (i.e. play pause music) with a single press. However, the keys on the left hand side (F15-F19), as well as F14 at the top right all report their respective Fxx value to the operating system and can be used in Keyboard Maestro as F15 etc.

The top row keys can be used as F10, F11 etc by combining with the "fn" key beside the "home" key. It now occurs to me that this is possibly quite different behaviour if you don't actually have a macOS layout Razer keyboard....

It is weird that the top row does their accessory functions, while the macro keys do their Fxx functions, but having never really used the top row for macros when I was using this keyboard a lot it didn’t bother me.

I've now disabled the "Use F1, F2, etc. keys as standard function keys" checkbox in settings and can report even weirder behaviour. For what it's worth, I usually have it enabled because I now use an Apple Magic keyboard and I like to use the top row for my macros as it doesn’t have dedicated macro buttons. Anyway, with the checkbox disabled my Razer keyboard still reports macro keys identically to with it enabled, but the top row only does the accessory function regardless of whether or not I press the fn key.

Finally, if this is at all useful and you'd like me to try different keyboards I do have two other Razer keyboards. An identical model to this one, but with the windows layout, and a ten keyless "Tournament Edition" from around 2015. Happy to try those, but I'll need to get them out of their boxes (wherever they are) to do so.

1 Like

Vincent, that's so kind of you to check that keyboard and to offer to do the same with others.

It's pretty clear that MacOS doesn't recognize my Razer Black Widow Chroma V2 as a "Mac Keyboard," as I noted in my first post in this thread.

No sense in working on this any further -- but thanks.

No more Razers for me -- ever. This thing has sucked from the beginning, and has sucked way too much of my time and energy -- and now the time and energy of my KM Forum friends!

Thanks again.

@KMfan tried Steermouse app?

Thanks, Regular.

If KM can't do it, I don't want to add additional software.