Date problem (wrong language) After Upgrade to Mojave

Hi !

I used to get dates in my mac configuration language (french) :
Example :
%ICUDateTime%MM-MMMM% ➜ 10-Octobre.

Since Mojave (I guess ?)
I get : 10-October (english language instead of french language).

I double checked my mac configuration.
System Pref > Language & Region
My primary language is french.
Advanced... > General tab ➜ I see dates correctly displayed in French

But anyway : dates are in english in my macros.

Any idea ?

Thanks in advance for your help !

Hey Laurent,

That suggest Mojave has broken some localization stuff.

For now the only workaround I can think of is find/replace.

You might create a macro with the simplest possible test case that fails for your and post it, so Peter has something to test that he doesn't have to create from scratch.


Yes, it does seem to give English results even if French is set as your primary language.

I don't know if Apple considers this a bug or a feature. Maybe it thinks that because Keyboard Maestro is not localized in French it should give English results.

I'm not sure there is anything I can do about it though. Hopefully Apple will undo this change.

Thanks very much for your answer.
I guess in the meantime I have to use "Search & replace" in my macros to translate the months manually.

Does %LongDate% return the correct language?

No, same thing unfortunately

By the way Peter...
I have to say that KeyboardMaestro changed my life and my business.
I'm so gratefull. Thank you !

In some respects that's good (at least for me), because that code path is simpler, which means it is almost certainly either Apple’s bug or Apple’s decision. If it is Apple’s bug, hopefully they will fix it promptly. If it is Apple’s decision, then hopefully I can eventually figure out a workaround since it's clearly a bad decision.


Same thing here. It should be simple to have any Token in the language of our choice.

It has always been in your chosen language, but unfortunately Apple changed the API call so that instead of returning your chosen language, it returns English regardless of your preferences.

I will find a workaround, but it requires a new release, and since the next release will be 9.0 and is not coming out any time soon, that means there will be a fair wait for it I'm afraid.

Any news (workarounds) on this issue. Last weekend I've (finally) updated my Mac to Mojave and unfortunately a lot of Keyboard Maestro macro's are useless now :frowning:

There is no workaround for this as far as the Keyboard Maestro tokens are concerned, the only other alternative is to generate the dates via other means (shell scripts, or maybe JXA).

Other than complaining to Apple there is nothing I can do to resolve this in existing versions of Keyboard Maestro, and I don't even know if I can resolve it in future versions of Keyboard Maestro - this is Apple’s choice of how the date system should work, since Keyboard Maestro is English, all the dates that the system gives Keyboard Maestro are English regardless of your preferences.

Hi @peternlewis,
thnx for the prompt reply and answer.

Suggestion: Maybe you can ask the guys of Typinator / Ergonis how they script the dates. Typinator is also an English app, but the dates in Mojave are given in the language of the system.

== feek

1 Like

@peternlewis thnx for fixing this issue in KM V9.0! I know I can rely on such great software!

Thats also the reason I purchase an update before installing it :slight_smile:

Happy 9th anniversary!


1 Like

Yes - it is a bit of a nuisance in that now the UI for Keyboard Maestro will be half-and-half. Some parts English, some parts your defined language. But that seems a better trade off to get the date functions to do what they always did before Mojave.