Disable Wacom

The Send To option. Move the mouse over it.

gee... am i blind? :slight_smile:

Will make a macro to change all these! :slight_smile:

No worries.

I have another idea. Most programs have ways to use them even if there is no mouse. Is there any keyboard equivalent for the mouse commands you are using? That would certainly fix the problem.

Absolutely that would fix it. But no, i would have certainly used those instead.

You may be surprised at all the ways keyboards can be used in place of mice, but I have no choice but to believe you.

But one more thing. There's a feature in macOS that lets you use voice control instead of the mouse. Have you tried it? It lets you speak numbers to click on buttons. now if you combine that with the "type to Siri" feature, I can probably do miracles with programs that don't take keyboard commands.

MacOS goes a long way to ensure that handicapped people can use Macs without a mouse. I've used features like this to find ways to use the keyboard when I thought only the mouse was possible.

I just came up with a neat idea !!!!!

While your program is running, change the speed of the mouse to as low as it can go. That way any motion from the mouse will be totally minimized. Does the Wacom have a speed option too? Can you set that from KM? This isn't a perfect solution but I'll bet it will solve 99% of your problem.

When your program finishes, set the speed back to normal.

At the moment I don't know the best way to do that. But I'll bet we can find the right way with a little work.

Doing this should not interfere with your macro mouse commands at all !!

I tried reading the Wacom manual to see if they documented how to change the Pen speed from a command line. I didn't see it. But once in the past I contacted Wacom for tech support and they provided it to me (even though I don't own one!) So give that a try. You have the Wacom device so you should be the one to contact them. There's a good chance they will give you the answer. And even if they don't give you an answer we can probably get AppleScript to adjust the Wacom speed because Wacom appears as a pane in the System Preferences. https://apple.stackexchange.com/questions/333893/change-mouse-speed-in-terminal-without-restarting

I will contact them, good idea. I own 6 of these Wacoms i think... :slight_smile:
And i will try if i can 'applescript' the system pane so that it disables Wacom smoothly.

There is no 'pen speed' as the speed is the same as my hand speed. With a mouse a small movement can be a large cursor movement, judged by the 'speed' setting. That is not how Wacom works. The upper left of the tablet is the upper left of the monitor. So, you can jump from upper left screen to lower right screen at once, by holding the pen above upper left on the tablet, take your hand away, and place it back on the tablet on bottom right. With a mouse you have to 'push the cursor' to that place.

I see. I should have realized that. Indeed I've always wanted a Wacom for that reason.

I think the AppleScript I alluded to was only for changing speed, not disabling. So if you're going to contact Wacom anyway, ask them for a command line to disable the thing. I'll bet there is a way.

Is your Wacom connected via USB or via the optional Wireless dongle? If the dongle, then there may actually be an easy way to disable it !! I just haven't figured out how to do it, but it may be possible.

usb hardwired

add a Pause until > The screen contains the image, so first it finds the image, then clicks on said image.
...you could also force quit the wacomtabletdriver, not that I recommend it, but still...

If it were me I wouldn't mind doing a force quit, but to do that programatically I think he would have to use a kill command inside an Execute Shell script action. And then restart the program later. I see nothing wrong with that idea.

I was wrong... Wacom is Applescriptable. I was looking for "wacom" in the scripting dictionary but it is called TabletDriver.

There is not such a thing as disable pen, but there is a function that defines with part of the tablet is active. But when i hold my pen above an inactive part it is still moving the cursor. That might be a bug. I will contact Wacom. But i doubt they will fix it as my tablet is older and not supported by the current software version.

About the Force Quit icea, no need to force quit. Normal quit works.

tell application "WacomTabletDriver"
end tell

works to disable the tablet

tell application "WacomTabletDriver"
end tell

works to enable it but activating takes me too long to use in a macro that needs user action.

recently got a Intuos pro, works fine with KM.

It is best to use a Code Block with scripts. I've adjusted your post accordingly.

thanks, looks better that way

Wacom replied very swiftly.
In the TabletDriver there is no way to disable a 'transducer', ie; Pen. They did suggest to disable Wacom in the System Preferences>Security>Accessibility, however, that is not existent in my High Sierra. Likely it is in Mojave. Too bad. Have to find another trick.

Well, it may not be the hoped-for answer, but at least it was an answer. Maybe solving this problem in un-possible in your OS version. I'm out of ideas.