Disabled in an app doesn't seem to stick for me

hi, i moved a macro into a group "disabled in calendar" (that group is set to "available except in calendar") – i did this because i use the same hotkey in calendar for something else... and after i move it into that group, and even when i quit and relaunch km, it seems to work, but it only works for a while and then when it stops working i look and the macro is no longer in "disabled for calendar"

a screenshot is attached.

might anyone know what's going on? this seems to be happening in othe similar instances as well.

am i approaching this wrong? is there a better way to have the same hotkey do different things in different applications?

thanks! -todd

Its hard to know from that limited description of what is happening, but if the macro itself is being removed from the macro group, then there are generally only two possibilities I can think of:

  • It is accidentally being deleted, either manually, by some macro that is running amuck in Keyboard Maestro, or by some AppleScript that is affecting your macros.
  • Or, you have macro syncing turned on, and somehow the sync file is being reverted, or the other Mac is undoing the changes.

thanks for your reply, peter. i don't have syncing turned on and never have. i'm going to keep a closer eye on this issue and i'll report back when i might have some more info. thanks! -todd

hi peter, it just happened again, and i realized that i had the macro in 2 “disabled in” groups at the same time: it was in a group that disabled macros in mail, and it was also in a group that disabled macros in contacts…

could it be that when the macro stopped working in one app and then i moved it back into one of the two "disabled in" groups that this is when it disappeared from the other "disabled in" group (?)… BUT, i stopped investigating after this hypothesis and i just gave up and assigned a different hotkey to the macro to solve the problem (and i then removed it from both "disabled in" groups).

question: when i drag a macro from “all macros” into a “disabled in” group and then when i delete it from the “disabled in” group it seems to be gone from “all macros” as well and then i have to re-create the macro. how do i remove a macro from a group but still keep it in “all macros”?

thanks! -todd

There is no “All Macros” Macro Group per se - All Macros is a Smart Group.

Macros live in Macro Groups, and the Smart Groups are basically just canned searches. So the All Macros Smart Group shows you all your macros, but a macro does not live within that Smart Group. So you cannot have a macro that is just in the All Macros smart group.

oh! thanks peter…

2 questions:

  1. can a macro be in the global macro group PLUS in another macro group – or can a macro only reside in one macro group?

if a macro can only be in one macro group, then that might explain why my macros that were in 2 “disabled in…” groups kept disappearing – i thought i had them in 2 “disabled in…” groups at the same time but i actually kept moving them from one to another…

  1. if the above is correct, then to have a macro disabled in multiple apps would i have to make a group (which i could label “disabled in calendar + mail, for [name of macro]” and then disable that group in mail and calendar?



Only in one macro group. Macro Groups are like folders, macros are like files. Each macro is in exactly one macro group.

You can also make the equivalent of “aliases” or “links” by using the Execute a Macro action. And indeed, if you drag a macro from one group to another group, holding down the Command and Option keys, Keyboard Maestro will create an alias for the macro in the target macro group.

1 Like

oh, that's all great to know! thanks for your help, peter. (p.s. i'm so loving your km.)

1 Like

hi peter, i seem to be having the same issue though i'm using aliases in a "disabled in..." group...

screenshot is attached, labeled A and B:

A) i put aliases of same-hotkey macros into a "disabled in indesign" group, but...

B) when i use the hotkey in indesign, the conflict-resolution pallete still comes up

what might i be doing wrong? i don't want this conflict resolution pallete to come up, i just want the "horizontal scale" macro to work when i'm in indesign

thanks! -todd

hi peter, i moved this question to its own post, hope that was an okay thing to do: How can i use the same hotkey in different apps, but with no conflict palette appearing?