F keys not recognised as trigger when send from Elgato Stream Deck

I have an Elgato Stream Deck. For some reason, suddenly my buttons that send a F key are not seen anymore by KM. I recently updated their software to 3.1.1 and KM to 8.2.2.

Let me explain more.
On the Elgato Stream Deck i program a button to send the F8 key
I make a KM macro that is trigger by F8.
When making this macro i Set the trigger by "This Hot key" make KM listen, press the button on the stream deck and KM adds F8 as trigger. The action is t play a "tink' sound, just for testing purposes.

Now, when i press F8 on any keyboard it runs the macro and plays "Tink!"
But when i press the button on the Elgato Stream Deck it does nothing.
Remember, as said above, the macro was made to listen to F8 when i pressed the same button on the Stream Deck!
How come?

If i exchange F8 for any other non-F key, all works fine. So, i make a button on the stream deck that sends the key "y" and make KM listen to key "y" it all works as expected. But not the F1 F2 ~ F19 keys

This worked here before. I don't know what i have done that it stopped working. I tried to re-install both previous Stream Deck and KM versions, to no avail.

Just to test if my stream deck works: i have made a Keyboard Shortcut in System Preferences > keyboard Shortcuts. I made a shortcut in Text Edit for "Rename..." when F8 is pressed. When F8 is pressed on any keyboard it works, and when i press the Elgato button it works too. So, the Elgato is working.

hmm. Pity no-one has any clue.
Stuck between two developers.

KM trigger input set to listen; StreamDeck sends a press-key command F8, KM correctly reads F8. But then does not play the macro when i send it F8 from the StreamDeck. But does play when i press F8 on my keyboard.
If i do the same but with the number 1 key instead of F8 all is fine.

To figure out if the problem is with stream deck; i edit VLC hotkeys to make it listen to F8 send from StreamDeck. All is fine.

Ergo; there is a difference between key F8 and key 1 as send from the StreamDeck. No other application has a problem with that except KM.

Where's the cure?

I reverted back to Stream Deck software version 3.01 and the issue with KM is gone.
I wrote the developers.
Still, it is curious that KM is the only program that seems to bother about the way SD sends the F-keys.

Unfortunately, it is very hard to debug without access to the hardware, and I guess no one else has the hardware.

Note that the Hot Key API is handled by the system, applications like Keyboard Maestro simple register the keycode and modifiers with the system and the system tracks the hot key and notifies the application. So there is not a lot of wiggle room if the macro is not being triggered, basically the system is not notifying Keyboard Maestro of the hot key press. It is hard to know what could affect this on Keyboard Maestro’s end I'm afraid.

You would hope that the Stream Deck developers know what they changed between the two versions…

I am happy to chat with them if they are interested, although again, if Keyboard Maestro isn't being told by the system that the hot key was triggered, then Keyboard Maestro is basically getting nothing.

One thing to try would be to check with other applications that use hot keys (and hopefully the hot key API as well). Apps that have a key to bring them to the front or perform some task while they are not in them are probably using the Hot Key API (eg Twitterific has a key to bring it to the front). Try them and see if the F keys work - if they don't, then it points to Stream Deck and gives them more reason to fix the issue. If they do, well, we'd still need to know if the app was using the hot key API, but it would be interesting.

And the other possibility is to use the USB Device Key trigger, but I don't know if that will work with Stream Deck either.

Unfortunately, it is very hard to debug without access to the hardware, and I guess no one else has the hardware.

I would suggest you buy one! I think you will like it. I even think you can start a collaboration, and implement the StreamDeck in KM. Their software is behind of what your KM can do. But, SD has a display to show icons. which is absolutely great. That's why i use their software.

if Keyboard Maestro isn't being told by the system that the hot key was triggered, then Keyboard Maestro is basically getting nothing.

Well, that is the interesting part. If i tell my KM macro to listen to a trigger-key, and i send the F8 keys using the SD, KM hears it and add "f8" as trigger. But when i fireF8 using the SD is does not play the macro, but when i press F8 on my normal Apple Keyboard is DOES play the macro.

Also interesting; if i use the Keyboard Shortcuts functionality in SystemPreferences Keyboard, all is fine and F8 is recognised. And, if i use the Shortcuts functionality in VLC it works too.

The solution is at SD since their software version 3.01 does work, but 3.1 and 3.1.1 does not. So they have changed something, something that only affects KM so far as i have found. May i pass on your email address to them in case they have a question? Like i said above, i would even like it if you get in contact!

1 Like

Sure, they can contact me at https://contact.stairways.com/

Did you ever get this figured out? I'm having the same issue with my Stream Deck in Stream Deck software 3.2 and keyboard Maestro 8.2.4.

No, i keep bugging Elgato, to solve the issue. If you roll back to 3.01 all is fine.
Please do the same! Maybe you can refer to my case. My ticket or issue number is: #809972

They first wanted me to upgrade from Sierra to High Sierra. Which i don't want, and was almost sure it had nothing to do with the issue. I did anyway, using a clone of my system so i could easily roll back. And of course, the issue persists on HighSiera, just as i thought. I reported to them, still no answer that they can reproduce the bug.

The odd thing is; if you assign a button as Hotkey and choose F8 for example, and make KM listen to a keyboard trigger, it will see the F8 coming from StreamDeck. But, after that, it won't trigger the macro.

Maybe it would help if we can reproduce the bug with other applications beside Keyboard Maestro.

Hope they will solve it!

Funny I'm on Sierra too. Maybe that is part of the problem. I would upgrade, but I work in the film industry managing footage on set. Ive been working on the same movie (actually 2 movies filmed back to back) for nearly two years. I'm afraid it would cause problems with software compatibility to update. I never update mid project. Maybe I will try this out with Mojave when I finish up here in about a month.

But yeah I'm going to bug elgato about this.

If you use another application that has a hot key, does it result in the same lack of behaviour? For example, Twitterific has a Hide & Show windows hot key (in the Advance preferences). Other applications have a similar behaviour, and usually (but not always) they will use the Hot Key API, in which case they should (I suspect) suffer the same behaviour.

Peter, i only tried it with the OSX's own keyboard shortcuts, in System Preferences > Keyboard > Shortcuts, and that works as expected.

Shutter; save the trouble with updating to HS, i tried, it doesn't help.

I've had one of these on my radar for a while. Once I heard the new models has less keys, I was sold on the regular stream deck. I just picked one up. If you need help testing anything let me know.

Partly fixed in 3.3. Some keys still have the behaviour. Testing now.



I am working on Stream Deck. With the help of @peternlewis, we found a solution to the issue where the F1-F19 keys would not be recognized by Keyboard Maestro.

We just released Stream Deck 3.3 which should address the problem.


This is awesome! I just installed it and so far everything seems to be working really well! I have My F-Keys back! Thank you! It's fantastic to see two different companies with awesome products work together to solve an issue for an small group of users. This is incredible! I hope we see more cooperation between these two companies in the future. Integrating the Stream Deck with Keyboard Maestro makes both products sooooooo much better.

Thank You!


Heya Timac,
Good you are working together with Peter on this. I really appreciate it!

I did a test and found these keys are still not working and behave like the previous SD version:

Page Up
Page Down
Forward Delete
Left Arrow
Right Arrow
Up Arrow
Down Arrow

Timac, do you want me to add this to my bug previously send bug report #809972?

How can I get a copy of the test version?

I've also noticed if you set a key to do type text, and configure the KM trigger to the same typed trigger it fires in stream deck types the text but KM won't recognize it as a trigger.

Thanks for the feedback! We will look at these remaining keys. No need to update your bug report.

1 Like

HI Timac,

Any news on this? Looks like a small bug fix for me as the other keys are fixed in the latest update. It would certainly help KM users!