Feature Request: Turn Off Status Menu Animation for Specific Macros

I have some macros that run very often — one that runs whenever the focused window title changes, and a few that run automatically every couple of minutes. (Don't worry about performance — they each check state and abort in 99% of cases.)

This means that the status menu icon is constantly doing its little animation for half a second, which is distracting and not useful. It would be great to be able to specify those macros and tell the status menu not to animate when they run.

Thanks for considering, @peternlewis.

1 Like

I use the 'Classic' icon and it is barely noticeable. Of course if you want to know when other macros are running, you may need the other icons with more 'show'.

Just a suggestion. Having the choice of turning them off by individual macros is of course the ideal solution.

Yeah, I'm using the Command status menu, mostly because I prefer it aesthetically. But it is useful when I'm testing macros to be able to see when a macro is running — another reason it's unhelpful to have the animation constantly firing in response to my background macros.

I use the Iconaholic Loud icon set, because I want to know when Keyboard Maestro is running.

This has saved my bacon more than once.

Ordinarily I don't have long running macros firing in the background, but that might happen in future – and I can certainly see the utility of having more control over the process.

Amusingly enough, there is already an internal way of doing this. There is an internal private action that can be added to the front of a macro and the status menu wont animate if that action exists as the first macro. There just isn't any way to actually add this action.

I've attached the action, but I make no promises as to it working for any specific purpose, but since I probably wont implement this feature request, using it is probably your only option to accomplish this.

hkDontRotateStatusMenu.kmactions (365 B)

Keyboard Maestro Export


Nice! Works just as I had hoped. Thanks Peter.

UPDATE: I spoke too soon. On this macro, which checks for specific websites in Safari, the animation still fires every time the window title changes:

Respond to Specific Websites.kmmacros (27 KB)

Any ideas @peternlewis?

Works fine for me - are you sure there isn't another macro triggering?

1 Like

You're right! I forgot that I was using a KM macro to change the keyboard shortcut to switch tabs in Safari, and another that checks for full-screen mode. It goes to show just how deeply KM is embedded in my computer usage. Thanks again for your help and for this invaluable application.


Thank you for this Peter. I have a few macros that run every second, but I really don’t need to see the icon rotating for those particular macros.

Fair enough. Do keep in mind that frequently running macros will be a CPU and battery drain to at least some degree. I work very hard to ensure Keyboard Maestro in idle state uses almost no CPU, but if macros are running I'm more concerned about getting things done.


Thanks for sharing this Peter!

After a few minutes the animation begins again, any way to stop that? Thanks

I don't know what you mean.

The action only affects the specific macro it is in. And only if it is the first action in the macro.

It might be better to start a new post with your issue, including more details, and if possible, the macro itself so we can see what’s going on.

Hey KB gang! I tried this and it didn't work. I tried few different things like putting the macro in global macros, and messing with the icon settings but nothing works. can someone help me with this? im using a timer that only counts when my program is at the front, since it running so much, I would like to not see icon spinning, so I will be able to tell when other macros are running or not.

here my macro.
Screenshot 2024-04-18 at 1.04.36 AM