File Maker Pro Macro won't work after Mac upgrade

I upgraded to Keyboard Maestro 8 and my Mac to High Sierra and now my previous macros for File maker Pro no longer work and I need them to work for my business. Please help me!

Hi! Can you post some more details? Can you post the macros that broke? What did they used to do, and where are they breaking now? etc.

All the macros are like this. It creates a pdf of a letter in Filemaker Pro, Puts it in an email, puts the persons email address in the proper place, pastes a line in the subject field then more in the body of the email and then moves the curser up to put the person's name after Dear.



I figured out the problem. The print dialog box for the mac software has changed. You used to be able to identify the print pdf to email using Control, shift, command, x. In the new version there is no option for that and the command appears two lines further down in the menu. Any ideas to work around that?

I don’t have FileMaker Pro, and I also don’t see a “Print PDF to Email” option in the print dialog for other standard Mac apps on my own Mac running High Sierra; only ones for “Save as PDF” and “Send in Mail”. Could you provide a screenshot of what the print dialog looks like in FileMaker Pro on your system?

It would also help if you could post a full macro, rather than just a partial screenshot. If you’re not sure how to do so, you can find instructions here, in the “How to Post/Upload Your Macro to the Forum” section: https://wiki.keyboardmaestro.com/Forum

One more question for now: are you using Mail.app to send these emails, or a different email program like Spark or Airmail?

These are the screen shots of the two different print menus. The second one is from the new High Sierra the other from my laptop which thankfully, I didn't upgrade.

So the problem isn’t with Maestro it’s with the new configuration of the print menu with the Mac. I can’t figure out how to get around it and I need to.

Okay, I think this should get you started:

Select Option in Print Dialog.kmactions (4.3 KB)

Try replacing the first three actions of your macros with these, make sure the number of repeats lines up with the circumstances described in the comment, and see if this doesn’t work any better.

Thanks, I’ll try it in the morning when I have time to mess with it. I’ll let you know how it goes.

Jeff

If “Send in Mail” does the same as the old “Mail PDF”, you probably can just adjust your System Preferences, Keyboard preferences, Shortcut preferences, App Shortcuts preferences, All Applications.

My guess is you already have an entry in there mapping Mail PDF to Command-Control-Shift-X, and you just need to change the title of the menu in the settings from Mail PDF to Send in Mail.

1 Like

Instead of worrying about whether it will take 4 or 5 shift-Tabs, I think you can just use a “Press Button” action with PDF as the label.

1 Like

So my "print to Evermote" macro looks like this:

Huh, so you can. I didn’t think that dropdown menus like that were considered to be buttons, so I didn’t think that was even an option, but I’m happy to be proven wrong. Thanks for the tip!

I’ve also confirmed that Peter’s suggestion of setting (or re-setting, in this case) a custom keyboard shortcut to that option in System Preferences works to restore the original shortcut-cased method as well, so @Laughmaster should now have multiple robust options available to get his macros working again.

After all I’ve learned from your many posts, I’m glad I was able to provide a smidgen of a tip that you find helpful.

1 Like

You guys are over my head on your advice. I’ve never done anything like that before. Is this something I do in KM or in the actual Mac system?

I checked and I don’t have any entries in there mapping Mail PDF. Is this something I need to do? If so, how?

Thanks,

Jeff

This is what my keyboard Shortcuts looks like:

Here's how to restore the shortcut so that your macros continue to work as-is. In that keyboard shortcuts area of System Preferences, click the Plus button to add a new shortcut, type "Send in Mail" for the shortcut name, and press ⌃⇧⌘X. It should look like this:

To ensure that it's working, open a print dialog in any app and make sure that the shortcut is listed there:

Once this shortcut is restored, all of your macros that use it in the way shown in your sample screenshots should continue to work like they did before.

You are Awesome Gabe! That did the trick.

Thanks!

Glad your problem is solved.

I know that @gglick provided you with several key parts to the solution, but please choose the one that covers the most of your issues, and check the “Solved” checkbox (click for details) at the bottom of that post.

This will help future users/readers quickly find the solution to issues like yours.

Thanks.