Help! (Finale) Macros Will Not Trigger

Hello KM folks,

Recently, I've ordered Keyboard Maestro for use in my work with Finale's music notation software, but am having fundamental problems with firing any of the Finale macros. (This extensive set of macros incorporates 487 macros to date organized in 23 “groups" developed by a core group of professional Finale music engravers.)

I am able to fire simple default KM macros like "Activate Window Switcher” using the “Run” or “Test” buttons in the editor window. But neither of these buttons trigger the imported Finale macros. The message, pasted below, pops up whenever attempted...

{Tech Notes:

  1. I have installed and re- installed both the JW Lua & JetStream Finale Controller plug-ins required to trigger the Finale Keyboard Maestro macros within the Finale program environment along with Keyboard Maestro itself, including the associated prefs.
  2. Within Finale, I'm able to access the JetStream plug-in via the plug-in menu & then manually enter appropriate codes to achieve the intended results. But of course, that is merely a (constant) workaround imposed because I’ve been unable to resolve the non-communication between KM & Finale.}

Also, if it helps–I bought Elgatos’ Stream Deck device to use with Keyboard Maestro & Finale. It does work with Finale running native Finale scripts that do not go thru Keyboard Maestro. However, whether using the “official" Keyboard Maestro plug-in for the Stream Deck, or the popular KMLink plug-in, my results have been the same as when I attempt to run Finale macros directly from the KM UI.

My thinking is that this should all be relatively straightforward to set up & start humming, however… I’m stumped!

Thanks, Joseph Williams

Some initial thoughts:

Are the groups enabled? Click on the group and see if the checkbox is enabled:

Are the groups dependent on a specific version of Finale that you don't have? If so, click the little arrow-things and select your version of Finale.

Are the macros themselves enabled?

That's all I've got right now.

1 Like

Dan, thanks for the input. Yes, I've been careful to see that the macro groups & also the individual macros are both enabled. The download & installation directions for these macros specify that they are compatible with my version of Finale (v. 25). I am mystified as to what the problem might be, though appreciate your thoughts. To be sure, all advice is welcome—there is an answer to this!

1 Like

Exactly how did you determine that the macros weren't "triggered"? Sometimes macros abort after they are triggered. (And failing does not need to imply a fail pop-up occurs.) Did you turn on the debugger to actually see if they were being triggered? (Ensure that the Pause New Macros button is checked.)

Besides this, I recommend that you try a few of the macros by manually trigger them using the Try button at the bottom of the right pane when the macro name is selected in the left pain. Do you get a different/better result?

These two tests may help to uncover the problem, or give us a lead.

There's also the KM log file, but these tests may be easier than doing that, for now.

1 Like

Hmm, I only assumed they were not triggering as I could see no change of any type.
I have selected the "Try" button for a dozen or more of the Finale macros ... nothing.

As a newbie, I'm not familiar with the "Debugger". I tried to apply it within one of the macros however and selected the "Debugger Pause New Macro" option. Again, I see no effect, but get the same screen alert as above.

Wish I could be more helpful; will the KM log file point to anything?

That's a clue. It tells me that the KM Engine is running. I wasn't quite convinced, although your error screenshot seems to suggest it. So if the Engine is running then the Log may have more clues. Open the Terminal app and type this into the window:

tail -f ~/Library/Logs/Keyboard\ Maestro/Engine.log

And keep the terminal window open. You will see new log lines whenever the KM Engine updates the log file.

While you do that I will ponder what to do next. Once you've got that going, stop and restart the KM Engine using the KM Editor (at the bottom of the File menu) and see if you see any error messages in that Terminal window appearing.

Then try to run one of your macros manually and see what appears in the Terminal log file window. There could be a big clue there.

If we don't see any clues, we may have to check with your software and hardware companies to see if everything that you've put together is compatible with each other. For example, maybe you are using macOS Monterey and that might not be tested or compatible with your software. Just an idea.


Will do Sleepy. I've typed (pasted) your text into the Terminal window & assume that I should send or post the log after I try KM next. For now, off late to bed & am looking at a hectic day on the run tomorrow.

I appreciate your assist & will get back ASAP, perhaps after you've had time to "ponder what to do next."

Thanks & will reply on the board in the interest of anyone who may be monitoring this thread.

That's a great attitude - not everyone has it. Thanks!


I think what I would first do as a basic test is make my own Macro for Finale in a brand new Group and see if that works. If it does work then the problem is to do with the imported Macros and not with Keyboard Maestro/Finale.

Make your own new Group in Keyboard Maestro and call it something like "Finale Test Group". Set it to work in all Applications.



Now make your own very simple Macro in this Group that does something very basic in Finale - I would suggest getting Keyboard Maestro to invoke the menu Item "About Finale" which must exist. (In my case I don't have Finale so, I've done this with the Calendar App).
Select the Menu Item in the Action dropdown list like this:


Set a hotkey for this macro - something that is unlikely to invoke anything else (I chose ⌃⌥⌘X)

Now open Finale and run the Macro by pressing the hotkey. There are two possible outcomes:

  1. The About Finale Window should pop up. This will at least tell you that Keyboard Maestro and Finale are working together. From there it is then a question of working out why the Finale Macros you downloaded are not working.

  2. If the Finale Window does not pop up that is good info too, as the means Keyboard Maestro is not talking to Finale.

If the the result is outcome 2) - I think my next step would be to edit the Macro to work in another App (maybe Calendar, as in my example above). Open Calendar, run the Macro and hopefully "About Calendar" will pop up.

If it doesn't - my guess is that Keyboard Maestro is not being given permissions by the Mac OS - but that is jumping ahead...


Very good idea.


Zababon, Thanks for your sensible suggestion. I agree with Sleepy, "very good idea", and I will try it out to see where inter-app communications stand.

Meanwhile, here is a follow-up to my Dec. 10th post with the Finale community & what I can report as of today after observing some pointers from another user:

I've carefully & repeatedly installed the JetStream Finale Controller (plug-in) for Keyboard Maestro & Stream Deck profiles but continue to be unable to trigger Keyboard Maestro Finale macros using either the Stream Deck or from directly within the Keyboard Maestro editor via the "Run" button.

I get new alert messages (below) saying that the macro failed or was canceled because the menu item JetStream Finale Controller could not be found.

In fact, Nothing at all appears to happen when attempting to Run the enabled Finale macro as is...

However, when I go in and manually select the menu item: "JetStream Finale Controller" (in the first action area of a given macro), at least then the JetStream Finale Controller will render on the screen when I hit the "Run" button. However, the macro's required 4-digit code embedded in the macro does not get entered into the menu, nor does the OK button get pressed. Of course, if I then type the specific numbers manually, the macro will run. But, as there are over 400 of these Finale macros & since I do not have a numera-graphic memory, I need the macro to run its full course!

I will try Zabobon's suggestion. Meanwhile, any ideas about what is causing this, or what might be done to remedy the problem?


I created an "About Finale" menu selection macro as per your suggestion. As you can see, it worked. So, KM does appear to be in communication with Finale.

I have made some slight progress—or at least am identifying a sequence of behaviors more clearly: It seems that any of the Finale macros will run if and when:

  1. I manually re-enter the default path to the JetStream Finale Controller into the programmed (menu selection) 1st action.
  2. I click "Run" twice! (Not necessarily a "double-click".) To explain: Nothing happens on the 1st click, but the 2nd always brings up the JetStream Finale Controller numeric field (Finales KM plug-in) which sits empty & inactive on the screen until...
  3. I am then able to click anywhere on the score inside the Finale window, and presto–the 4-digit code is entered & the macro fires.

Of course, these workarounds make using the KM Finale macros nearly impossible; besides, I hope to use the Elgato Stream Deck which I've also recently added to streamline my work. (FWIT, these are the same 400-plus KM macros used by nearly every professional Finale music engraver.)

Hopefully, these behaviors might point to something helpful...?

Hey Joseph,

Do not test macros by hitting the run button. While “run” has its uses – it tends to cause problems for people who don't thoroughly understand how it works.

Give your macro a keyboard shortcut and test with that.

Your macro group for Finale should be app-specific, so make sure you are in the appropriate context (your app frontmost) before triggering your macro.



I hope you don't mind a little joke here... a couple of days I claimed that the #1 rule of computing was to "try everything twice." You've proved me correct here.

On a more serious note, another way to "try everything twice" is to substitute questionable components for different components. Last month I substituted a cable in my network and my network speed increased. What hardware components do you have that you can substitute? Well, you have your Mac, which means you could try another Mac. And similarly you could arguable substitute Finale by cleanly reinstalling it. Did you open a Terminal window and look for errors when your macros are failing? You may not get any more information than the pop-up you already showed us... but you MIGHT get more information.

1 Like

So, my next question is - are you activating these Macros when Finale is the frontmost App? It sounds like you are activating them whilst Keyboard Maestro is the frontmost App which won't work if the Macros are set to run from within Finale.

As @ccstone has suggested, give one of the problematic Macros a keyboard shortcut as its trigger, bring Finale to the front and press that keyboard shortcut. Hopefully all will work as intended.


Wow, that's a good theory.

1 Like

Back from the Xmas wonderland...
ccstone, I tried (several times) giving the macro a keyboard shortcut then trying it with Finale the frontmost app. Still no response. Unfortunately, still the only way I've been able to trigger the KM macros is by pressing Test or Run from KM itself. The mystery continues... (I wonder if reinstalling Finale would potentially-or likely be a good idea? Your thoughts?)

Sleepy, Glad to have proved your "try everything twice" computing theory as correct!

I'm back from the xmas holiday...

Yes, I have a 2017 iMac running Sierra for software/system compatibility.

As I recall when opening the Terminal, it didn't reveal any specific problem with KM.

I wonder if, as you seemed to suggest, reinstalling Finale might be justified or helpful? I hate to do that because of prefs but suppose I can save settings prefs and avoid too much disruption. Any thoughts?

Zabobon, I have programed hot keys for various of the many Finale KM macros & attempted to trigger them from with Finale as the front-most app. Nothing happens. Strangely, (as I described before Xmas), in the KM edit window action, I have to manually reselect the Finale Plug-in menu item that integrates with KM, and then press "Test" twice, then click the background Finale app which finally triggers the macro. If I program a Hotkey for any KM Finale macro, nothing happens when trying to trigger it within Finale. I'm stumped & considering reinstalling Finale. Any thoughts?

Happy New Year everybody! (Is there a macro for that?!)

This would suggest the problem is with the “new” imported Macros rather than anything to do with Finale App or Keyboard Maestro.

Are these imported Macros a) enabled b) in a Group set to work in Finale c) if the answer to b is yes, is this Group enabled?

It would help if you uploaded one of the problem Macros here together with a screenshot. If there’s an obvious problem that will help people here to spot it.

EDIT - To upload an example Macro to your next Post you could follow these instructions (adapted from the Wiki):

Manual Upload

  1. Click on the macro name in the Keyboard Maestro editor

  2. Goto File > Export Macro, and save to the Desktop

  3. Go to Edit > Copy as > Copy as Image

  4. Open Mac Preview app, and goto File > New from Clipboard, and save to the Desktop.

  5. You now have two files sitting on your Desktop (the image of the Macro and the Macro itself).

  6. Go to the Keyboard Maestro Forum thread, and click on reply

  7. Enter your reply message.

  8. While the reply is still open, drag and drop the two files from the Desktop into your reply. You will see the image of the Macro in the Forum Preview window.

  9. Click Save Edit.