Help please with Get/Set File Attribute - Date Created

Anyone know why the following doesn't work?


I get this error:


It's not an issue with the file name variables - I tried it with hard-coded file names, and the "Set" still failed.

I'm trying to set the creation date of one file to the creation date of another file. My guess is that "Set Date Created" expects the date to be in a different format, but I haven't the faintest idea what format that would be, nor do I know how to convert the result of "Get Date Created" to that format.

I'm probably blind, but I couldn't find anything helpful in the wiki on this.


This is just one more reason why you should hurry up and upgrade to KM 8 :slightly_smiling_face: (although perhaps you already did and just overlooked this):


This is a calculation field (as evidenced by the little C) so the standard variable syntax won't work here. Try csrxDate as-is and I believe it should work as intended.

Thanks. That solved the problem. Much appreciated.

I do in fact have version 8.1.1. And as you can see by this picture, it does not always display the "c":


Not only that, but if I select the drop-down and select the variable, it enters it with the "%Variable%" syntax.

@peternlewis - This looks like a bug to me. Thanks.


No problem. Considering how helpful your KM tools have been, I’m glad I was able to help in return, even just a little :slightly_smiling_face:

I can also confirm that the c does not always appear in that field, which does indeed seem like a bug, and that the drop-down enters variables with the %Variable% syntax.

Thanks. It was actually nice to receive help, also! Not that I haven’t received it before, but you know what I mean. :slight_smile:

1 Like

Fixed for the next version. It did not correctly identify the field until the menu was selected after the action was displayed.

I have also adjusted it so the popup menu inserts variables if it is a calculation field, rather than tokens (for token fields).