Hide some macros from palette?

When displaying a Palette from a Macro Group, is there a way to hide some macros so they don't appear in the Macro Group Palette?

Just want to know if there's a way to avoid creating a new a macro group to move the ones that I don't want to be shown there.


The only way I know of is to either disable or move them.

One workaround I have used is to have a main Macro Group NOT set as a palette.
Then a separate MG that has Alias Macros that point to the actual macros in the main MG.

nice, didn't know about that, thanks

Here's an example of something I do:

I have these macros:

  1. Enable Timer
  2. Disable Timer
  3. Timer

The macros 1 & 2 either enable or disable the Timer macro (#3). In addition, they either enable or disable 1 & 2, as needed:


This way, only macro 1 or 2 are visible at any specific time.

Hope that helps.

1 Like


I have a very similar method with my TimeTracker system.

Before I have punched in, my Macro Group and Palette looks like this:



So the "Punch OUT" macro is disabled and does NOT show in the Palette.

But after I punch IN, the Palette changes to this:


Notice also that the "Status" macro actually changed its name to show data about the task I punched in to. My "Punch IN" macro has these actions to handle this:


Here's the script that changes the "Status" Macro name:

property ptyScriptName : "Set Time Tracker (TT) Status Macro Name"
property ptyScriptVer : "1.0"
property ptyScriptDate : "2019-05-20"
property ptyScriptAuthor : "JMichaelTX"

property nameRoot : "❗STATUS:   "

tell application "Keyboard Maestro Engine"
  set taskTitle to getvariable "DND_TT__Work_Task"
end tell

tell application "Keyboard Maestro"
  set oMacro to macro id "E88C0241-A09A-4BBC-89F7-B9B31BAD6804"
  tell oMacro
    if (taskTitle ≠ "") then
      set name to nameRoot & "IN: " & taskTitle
      set name to nameRoot & "OUT"
    end if
  end tell
end tell

Note that it DOES require the KM Editor app to be running. But then I have it running virtually all the time.

1 Like