Hot Key Not Working on One Macro

I have a simple macro to activate an app whose hot key has stopped working. The same macro runs perfectly under "run" within the Editor or with a menu item selected. It even runs with the hot key if I have the Editor open. I have tried reassigning different hot keys but none of them take effect. I have a series of similar macros activating different apps that all work fine on the same machine. Does anyone have an idea on what might be wrong or how to troubleshoot this? I have already consulted, "How to Troubleshoot Keyboard Issues" to no avail.

At a guess I would think it is in a Group that is set to be Active when Keyboard Maestro is at the Front.

Are the Macros that work successfully in a different Group to the one that doesn’t work?

1 Like

No, they are all simply in the "Enabled group".

Have you tired creating a brand new macro in the same folder with a different hot key to see whether it fails like this one does, or succeeds? That might indicate to us if it's the macro or its group.


Creating a new macro resolved the issue. I should have tried that before writing to the forum. Sorry about that. I still haven't found what led to the strange behaviour of the previous version of the macro. But all is well and good. Thanks for your help.