Hotkeys Stop Working Over Time

Hi gang, I've been having a problem since (I think the last) KM upgrade. I'm using 9.1 and it says there are no updates available. I'm on Catalina 10.15.7.

What happens: On startup all my hotkeys work as expected. At some seemingly random time my hotkeys stop working. Abbreviations still work so .atm expands into "at the moment" but hotkey triggers don't work.

For instance I have ⌃⌥⇧⌘ T open a conflict panel to choose my most often used macros. It works for a seemingly random time, usually a couple of hours, and then just stops working. I was using a Karabiner-remapped Caps Lock to do the modifiers but it won't even work with pressing the individual keys.

To troubleshoot it a bit I made another macro that is ⌃⌥⌘Z (no shift) that just shows a notice but it also doesn't work when this happens.

Workaround: I wrote a little Automator Script App that lives on my desktop that does the following:

on run {input, parameters}
   tell application "Keyboard Maestro Engine"
   end tell
   delay 3
   tell application "Keyboard Maestro Engine" to activate
   return input
end run

I know, not impressive, but this works every time to get KM going again with hotkeys. That's why I come here looking for any ideas as to what's wrong or how to solve this. I'm not doing crazy advanced stuff with KM, mostly abbreviation expansion and program launching with screen repositioning.

The really strange thing is that it happens during the day and I can't put a finger on anything that causes it to stop working. If it were from the start I'd say I have something twisted in the macros or settings but since it works for sometimes hours I am confused.

Ideas? Thanks!

Hey Jim,

I'd try toggling the Keyboard Maestro accessibility permissions a time or two just for giggles.

@peternlewis – any other reports of this behavior?


1 Like

Thanks Chris, I've given that a try with a system update and reboot in the middle so everything that can "click" should. I'll let you know how it behaves as I use it more tomorrow.

I ran all day today with no issues. It usually happens at least once a day. I'll assume toggling permissions worked and if not I'll come back with an update. Thanks for your help! I would have never thought of that.


Rats. Sorry guys. It did the same thing again today. The mystery is still in play. Other ideas?


Time to formally make a bug report to Peter:

Peter Lewis <>


1 Like

Thanks, Chris. I'll do that. Should I mark solution or leave the thread sit?

Just leave it.

But come back and document the solution if/when you find it.