How to disable the notification of "cancel all other macros"

Hi there, really love the KM, just a quick question that I couldn't disable the notification of the action "Cancel all other macros" .

Every time, my action is running, it shows the notification which is quite annoying to me.
Could you advice how to disable it, preferbly only within the action. (Couldn't find any option to do it).

Also I know I can disable ALL the notify from OSX system control which it's not a best way to do so.

Thank you in advance.

BTW , searched and did this , it seems doesn’t work at all. Nothing changed. (Yes or No)

at the terminal to type:
defaults write com.stairways.keyboardmaestro.engine “Notification-Macro Cancelled” -bool YES


defaults write com.stairways.keyboardmaestro.engine "Notification-Macro Cancelled" -bool NO

doesn’t seem to have any effect here either.

There should be no space in the key.

defaults write com.stairways.keyboardmaestro.engine "Notification-MacroCancelled" -bool YES

perfect. Thanks. it works now.
The related help page should be corrected if it’s possible. :slight_smile:

Already done.

Hi Peter,

Can I please check if this setting still works in Mojave?

I typed it in terminal but the notification still pops up.


If you type it in exactly as shown above, it would be configuring the notifications to be displayed. If you want them hidden, it would be:

defaults write com.stairways.keyboardmaestro.engine "Notification-MacroCancelled" -bool NO
1 Like

I know this is an old thread but thank you Peter for sharing this info. I have quite a few work-related macros that start off by cancelling all other macros since it's critical that they are the only macro running when they are triggered. But this results in having a lot of those notifications constantly appearing.

So I disabled it using that terminal line you shared, and then added a simple notification to my global "cancel all macros" macro that way when I trigger it through my key-combo it lets me know it ran but if the action itself is triggered from within another macro it doesn't notify me.

Thanks again!

1 Like