How to make KM notifications not show 'Keyboard Maestro Engine'

I have a macro like this

When ran I see:

I would like to instead that it would show where the Keyboard Maestro Engine is, the actual content.

Reason is that I know from the icon that it's coming from Keyboard Maestro so I don't want to read those 3 words every single time (it's distracting). I want to just show the content.

Thank you.

something like above is what I want

The Display Text Briefly action might be closer to what you want, allthough it would be headed by "Display Text", instead of “Keyboard Maestro Engine”.

But for your specific use case, displaying the clipboard content, the Display Clipboard action might be what serves you the best. Set up like something resembling what I've done below will make it behave somewhat similar to a notification window:

SystemClipBoard, displayed notification style Macro (v11.0.2)

SystemClipBoard- displayed notification style.kmmacros (2.5 KB)

Edit: To display the clipboard even cleaner, I guess something could be done with HTML. But HTML is a subject I know next to nothing about

Yea neither of these options work for me.

SystemClipBoard, displayed notification style macro you shared looks off, I want the notification badge showing identically as it does otherwise my brain does not register it as such and it looks off.

I think @peternlewis should add an option to overwrite the top text as part of an action :pray:

Add some text in either Subtitle or Message, and the engine bit will vanish:


Edit: If you don't want any text, you can use the Hangul Filler, as discussed in this post. It will take up a line, but there won't be anything on it: